RTKBase: a GUI for your own Gnss Base Station

For older debian and ubuntu distros, doing things as they are now is just fine. With the policykit rules, all that needs to change is the user in the service file. Everything else should be transparent if the rule file is installed. I think the best information I’ve found on it is here: AKR Developer Blog | create a Linux systemd service and make it runable for non-root users. Looks like it has to be done with the group id of the rtkbase user. I don’t think sudo part is required (and wouldn’t be used by the web service anyway since it uses dbus).

I am trying to help my friend to install RTKBase for his Orange Pi zero 2.

What am i tried?:

  • installed the latest armbian (Armbian 23.8.3 Bookworm ).
  • tried the easy installation method - got error for: externally managed enviroment
  • tried to clone the use_venv branch and install - got error (Job for gpsd.service failed because the control process exited with error code.
  • then tired to copy the setting.conf.sample to setting.conf - still not working
  • the webserver starts

can you send me the beta link? guide me further?

Usually, you can ignore the gpsd error message.

For the beta : http://rtkbase.eu/rtkbase_beta/install.sh
And install it with ./install.sh --all bundled

No garantee :slight_smile:

Is gpsd actually needed? Most instances are going to be internet-connected anyway, so stock chronyd with ntp is sufficient.

is Raspberry Pi Zero enough to handle this project?

than you it worked, (after changing the usb cable) detected the recever, but not configured. ERROR:ubxtool: failed to import gps, check PYTHONPATH.
Manual copying the missing conf detals to setting.con and got gps fix.

A pi zero worked for this person. I don’t think I’d want my base communicating over wifi, but that’s up to you.
RTKbase img for raspberry Pi Zero - GPSD issue · Issue #175 · Stefal/rtkbase · GitHub

We are thinking the same way :stuck_out_tongue: But today I have free Pi Zero W, so I could give it a trial, and then buy a Pi 3B

How to get my base station correction and the begining?
I do not know exactly how to explain it, but I will try.
Pure F9P does not know the exact position of antenna. In general You need to connect to some RTK correction provider.
How to manage this step in this project? I read the manual 3 times and I did not get it.
Any hint?

It works to just copy/paste the F9P’s coordinates from the Status screen to the Settings → Main Service → Base coordinates

Everything will work, but if you ever want to do it again or to move your base then all your field boundaries will shift. Its better to use the built in file logging service, record a 24h or 48 hour log. You can convert this to Rinex and have it PPP’d by NRCAN etc.

What do you think about connecting Rpi 4 with F9P? Which one is better?
Connect by USB or connect by this device? Raspberry Pi adapter : https://www.ardusimple.com/product/raspberry-adapter-for-simplertk2b/

I am not a fan of USB connections for permanent installations, specially when that USB connection is in a box on something tall and I have a fear of climbing heights. For that reason I prefer the adapter device, its all serial and headers.

Configuring the UART on the Pi can be a bit tricky, but its doable. The exact procedure seems to vary between Pi models.

My own base station uses something similar of my own design, with a Pi and a micro F9P, running RTKBase. The connection is through serial just like the adapter that you linked.

What do you think about such hat?

can i ask a thicko question about this^?
im presuming you mean in ucenter?

reason i ask is my field boundaries will shift a few meters over months but i havent set up anything like this

In RTKBase. Once you get it installed those steps will become obvious, RTKBase shows the current location, has a place to enter the base station location, and has tools to take a log and convert it to Rinex for PPP.

That’s because you don’t use RTKbase?
Even with the F9P(and WiFi master, or anything else)you can use “fixed mode” instead “survey in” so your boundaries wouldn’t change a each restart.

I guess this is making your boundary move?


no, I don’t use rtkbase
f9p with wifi master sending to rtk2go
basically I’ve just switched them on, they work ,so I don’t meddle with things

I do remember seeing fairly long coordinates in ucenter when i first connected things and set the f9p as a base but as i dont now use ucenter

The long coordinates were probably ECEF coordinates (metres in xyz from center of earth). There’s a toggle in u-center to show them as latitude, longitude, and elevation.

i think they were lat/lon and about 8 numbers long
im assuming they would be fairly precise and that level

which option is best for rtkbase?