Startup/Connection Issues Kaupoi V4.1, Aurduino, Cytron BN008x

Hello all, I have the following system that I am currently trying to bench test and despite my best efforts to search the forums and YouTube for help, I am currently stuck :

Kaupoi V4.1 outfitted Board
Arduino Nano via serial and Ethernet Shield
MD13S Cytron motor controller and 24V motor
AGIO 5.7.2 and Autosteer USB V5.ino uploaded into the nano.
USB cable from laptop plugged into serial port on Nano

See photos of my setup attempt. I have a functioning on-off switch and an autosteer momentary switch that I am unable to verify at this time.

Problems so far:

  1. In several YouTube startup videos and reading the forums, it is often instructed to change the IP address. I’m not sure if this only refers to using UDP, but I am unable to do so using either work WIFI or my personal hotspot, as I get the “Can’t Save IP Settings, check one or more of your settings” error. Am I missing something here?
  2. As one can see in the pictures, there appears to be some communication via serial. The problem is that I only see one COM port as available (COM 5 in the pictures) and so I am only able to turn on one of the three inputs that I need at a time (GPS, Steering, or IMU). In order to turn any one on, I need to make sure the others are toggled off.

Hopefully this is making sense and appreciate anyone helping a clearly ignorant newcomer! Let me know if I can provide more information.

Hello and welcome, First of all you only need to change your ip adress if your using UDP, since you have a ethernet module you can use udp and i recommend udp over USB. If you choose udp you will need to upload autosteer udp ino and change your ip adress like in the video but fist upload the ino and connect a ethernet cable to the ethernet shield (enc28j60) and the laptop or tablet you plan on using, if your tablet doesnt have a ethernet port you can buy a adapter, then change the ip but not the wifi or hotspot ip but the wired connection (it will probably be called unidentified network).

Second problem your having is that this board you have is a autosteer board and can only be connect as a autosteer module, for gps you will need a gps recived most popular is ardusimple f9p. And lastly the imu if it is connected via kapoui board it will not be green in Agio bit it will work. Imu is only green if your using a seperate nano for it.

Thank you so much for the taking the time to help and for your patience! My laptop does not have an ethernet port, so I would just need to get a USB to ethernet adapter?

Copy that on the GPS portion; we bought an antenna that looks like it would plug into a board such as the one shown in this link

Is that advisable? The ultimate goal is to have autosteer and good enough precision for planting, so frankly I’m not sure what the best path is to get there and would welcome any advice.

Yes just buy a usb to ethernet adapter and a network switch. Also the gps reciver needs a antenna, looks like you bought only the board.

Like this, this is a kit, comes with antenna and electronics. This is a RTK capable board which means you can have 1cm precision while planting but only if you have correction, for correction you can check with agopen if there are any base stations near you or you can build your own ( I reccomend you build your own, if not now, in the future ).

For the F9P to work via UDP you will need this FS100P USR TCP232 T2 Tiny Seriële Ethernet Converter Module Seriële Uart Ttl Naar Ethernet Tcpip Module Ondersteuning Dhcp En Dns|Geintegreerde Schakelingen| - AliExpress
Here are the instructions F9P in ethernet mode
For testing or while you wait for this module to arrive you can plug the gps reciver in via USB and use it that way.

For a complete UDP system you will also need a network switch, this is like a usb hub but for networking. You can find pictures in the support folder \AgOpenGPS_Boards-master\Misc\Wirings picture is called 002-UDPSystem

Okay great, progress so far:

  • Ethernet adapter and network switch on order, hopefully all here by tomorrow

  • Serial ethernet converter on order per your link (great help, so easy to follow your instructions by the way)

  • I went ahead and bought a Land rover suspension sensor that was recommended multiple times in other threads for wheel angle sensing (RQH100030). Will need to figure out a harness solution as I don’t believe it comes with leads.

2 new questions:

  • With regard to IMU and the ADS1115 that is currently on installed on the Kaupoi PCB; are they of any value? How can I tell if they are working properly?

  • How would you recommend packaging/mounting the simple RTK2B board and ethernet converter? Is there a board that they should be mounted on, or just placed in a different enclosure, or is there a better idea out there?

Connector for RQH100030, you can also call a junkyard and ask for the sensor and connector just ask for Land Rover Discovery 2 height suspension sensor.

Connect the kapoui board to the tablet (depending on you ino connect with UDP or USB) nove the board left to right and vice versa you should see the yellow value change in the middle of the screen, that is your roll valu (IMU reading), the ADS1115 if its connected you little tractor on the middle of the screen should have its tires pointing to left, that is id there is no wheel angle sensor connected.

I used a proto board and soldered the USR-TCP232 module and simpleRTK board to it and a step down module, so 12V enter the step down module and on its output is 5V(you set this with a small potenciometer called a trimmer) and 5V are powering the USR-TCP232 and ardusimple board. Im guessing you can also use a linear regulator 7805 ( like the one on your kapoui board) to regulate voltage instead of the step down module. If this is complicated for you just connect GPS via USB for start.

My ethernet to USB adapter arrived and I uploaded the Autosteer_UDP_v5 onto the nano via serial port.

However, when I unplug the cable going to the Nano serial port, the indicator lights on the ethernet input to the Nano do not stay on and RX indicator light on top of the nano goes red. My computer is not recognizing the nano as part of a network (It just says “Ethernet 3 not connected”) and AGIO appears to not see it at all. What should I do?

Open serial monitor in arduino, and take a picture for me.

Did you set the ip adress of the USB to ethernet adapter to be 192.168.5.xx ( follow the video for more instructions, i wrote .5 because that is the default in the ino if you change that in the ino change it in USB to ethernet adapter settings. Did you also change the settings in Agio ( enable UDP, set the right ip adress etc).

Did you power the kapoui board with 12V when you were testing.

Make a video of everything, the board, the tablet screen and post it here.

Getting closer! I still need to have the arduino powered via serial port for some reason; when I unplug the serial port the laptop, the arduino becomes disconnected and loses comms even with the ethernet/UDP still plugged in.

My IMU appears to be working, as when I roll the board I can see the value changing in the AO simulator interface (yellow font).

I was unable to upload video even though I took a few, so here are some photos.

See photo of Arduino serial monitor with ethernet and serial/usb plugged in:

Lights on the Nano when serial is unplugged at laptop:

Photo of my steering prox switch connections which I believe are not registering (trying this as WAS even though land rover suspension sensor option arrived, just waiting on harness which is on order):

Photo of AG IO when serial is unplugged at laptop and ethernet still plugged in (shows the IP address for the Nano disappear:

Picture of AGIO when serial and ethernet plugged in:

Photo of Arduino IDE when serial is unplugged at laptop with ethernet still connected.

Did you by any change click on the little steering wheel and connect with the little plug or did you just connect the ethernet cable and thats it.

Really weird issue you have, when you upload the code to the nano and change the ip adress of the USB to ethernet adapter, connect everything it should just work. To me it looks like you connect with USB and thats why it disconnects the you unplug the USB but it should work like that if the UDP code is on the nano.

Try changing the ip adress to .2 instead of .5, try taking the nano and ethernet shield out of the kapoui board and power it with 5V with VIN (+) and GND (-) pins withouth the USB cable and report back here.

Ah, good call. When I measured across VIN and GND with serial removed, I get 0V. With it plugged in via serial , I get around 5V which explains why I need to have it plugged in. From the Kaupoi diagrams, I am unable to determine where the 5V is even supposed to come from on the board?

And I didn’t click on the little steering wheel that I recall, it just showed up green but only when connected via serial.

The wide red 5v is the one that feed nano. The other 5v regulator feed v +was(and ia also 5v)
The regulators have 3 legs and named vx7805

1 Like

Thank you, I have read a lot of your work in these forums and appreciate what you do for the community! After some troubleshooting, the problem was that my power supply was only rated for 100ma@15v. That was not enough to power the board components, even though the indicator lights flickered. Once I used a stronger power supply, problem has gone away and now I have 5V to nano. Cannot get Arduino IDE software to recognize my nano when connected via UPD only for some reason, but AG IO IMU showing up and responding to physical board movement.

Next steps:

  • Figure out how to make the steering motor work (Need to read up on this, assume I need to set up something in the simulator to make motor try and “correct”) Right now I have 24V at the Cytron board on the board input/output side of my 12/24VDC converter, just no voltage going out to my actual steer motor.

  • Once my ArdusimpleRTK and serial converter get here (thanks Stephen) I will dive into RTK.

That is the “drive” thing, in steering settings :slight_smile:

On github where you got the program , you also find a WIKI (not complete but have al lot) look at right side and scroll down.
The Manual is both there and in AOG (both under Help and directly as PDF in program folder)
Check out the FAQ

And watch videos click on youtube icon at top right here on this discourse page.

Thank you, I have the manual downloaded and using it now.

Ardusimple module has arrived, and I am using the Budget Survey GNSS Multiband antenna. I am not near a window currently, but it is connected (currently via serial until my ethernet adapter arrives) and recognized in AOG.

A current problem I have is getting the autosteer Motor (via cytron) to actually work. The tractor icon in the simulator stays red, and I have tried using either manual or remote steer switch control modes to turn on autosteer. The wheel turns green and it “corrects” in the program (tractor moves back to my AB line) but the physical motor connected to the cytron does not move. I am able to manually move it forward or backwards by pressing the “ma” and “mb” buttons on top of the cytron, but nothing with the program. The manual says the red arrow means the steer module is “connected but not enabled” what am I doing wrong?

Okay the problem is simple, by default aog is set up to need a switch to activate 4n33 optocouple meaning you need a switch or button connected to pcb to activate autosteer BUT you can still activate it withouth a button/switch, open the menu where you select motor driver, invert was etc, find steer enable and select none then send and save also if you have current turn sensor enabled, disable it for now.

Use simulator mode for testing because if you have a GNSS antenna connected to aog you will need to move more than 2km/h (default setting) to start autosteer if the autosteer is enabled (little tractor is green)

Wonderful, that worked! Something must be wrong with my switch, which I do have connected to the board but somehow isn’t being recognized. It is a D3V-162-1a4 and I have it used as button, I think (normally closed, when I toggle it the circuit would be opened momentarily). I have heard of bad opto isolators, but will need to troubleshoot that as well.

I think that is a button, set it up as a button and try it.

Hmm, seems like neither button or switch makes a difference. I have it connected between OVDC and ground as schematics show, does that seem right?

Yes that is correct, try this set steer enable to be switch and short the pins 0 and gnd, you can do this by disconnecting the switch and touching the two wires, if the little tractor turns green you switch is the problem. If nothing happens switch your 4n33 for another one, use the ones next to it, switch there places basicly.