I’m using STRSVR on a Windows PC to inject 1008 and stream the RTCM data online. I was having issues with it randomly stopping and thought it was due to an aging PC. I bought a new mini Windows PC but I still randomly lose RTK and even I check, the stream has quit and the USB port has changed. So I have to change the port and then hit start again. Any tips to make the system more reliable?

Make sure Windows update is turned off.
Do not leave mouse cursor on the start/stop field of strsvr, when leaving the computer ( You could stop strsvr if you hit Enter to open Windows again) Make sure if on wifi, that only one wifi router is available for automatic logon.

You can install ubuntu on the mini pc and install RTK base on it. Just install it, open terminal and run these lines one by one:
cd ~
wget -O
chmod +x
sudo ./ --all release

Thats it. now type your ip adress in a browser and RTK base graphic user interface will open. Simple stuff. Everything is explained by Stefal, the creator of RTK base on his github: GitHub - Stefal/rtkbase: Your own GNSS base station for RTK localization with a Web GUI

P.S Running on Windows or Linux you should always use ethernet over wifi, ethernet just works, wifi can be problematic, also set PC to never go to sleep and if your pc supports it enable power on option in BIOS, it just ensures your pc will always power on automatically if there is a power outage.

Hey thanks for the tips! I’m not at all familiar with Ubuntu. Can I remote desktop into Ubuntu from Android? I need to be able to access it this way so I can troubleshoot from the field.

I’m no Linux expert but I’m wondering what do you want to troubleshoot from the field? No need to troubleshoot the Linux computer, it just works. If you want to know how many satellites the base can see etc, use Ntrip checker or a similar app.

I used to run the old BKG NTRIP server and caster SW on Linux before moving to F9P and Stefal’s base. Neither one needing any troubleshooting.

1 Like

I should try it. I’ve needed it with Windows because if the PC restarts, the rtk stream doesn’t automatically start. Things like that.

Ok so I’ve tried this like three times and it seems to be successful. However, when I go to the IP address I just get an unable to connect message. And I’m worried it overwrote all my F9P settings that I had. Please help!!

the IP address the script gives me is the same as the IP of my pc.

When I run: sudo systemctl status rtkbase_web.service
I get the following:

● rtkbase_web.service - RTKBase Web Server
Loaded: loaded (/etc/systemd/system/rtkbase_web.service; enabled; preset: >
Active: activating (auto-restart) (Result: exit-code) since Sat 2024-05-25>
Process: 16117 ExecStart=/home/colin/rtkbase/venv/bin/python /home/colin/rt>
Main PID: 16117 (code=exited, status=1/FAILURE)

You should write on the rebase thread to get help, if you don’t get the web interface something is not working.

You can’t overwrite the f9p config with this process, even without the f9p rtkbase should install and work as a web page.

You can access your Ubuntu machine from the field but don’t have to, better solution is to install Tailscale, just two lines of code on Linux and an app on your phone, now the two are connected, copy the up address of the Linux machine that Tailscale gave you and enter it in a browser BOOM MAGIC that’s it.

1 Like

Alright. Can i move this conversation?

I’m wondering if it has to do with my Python version. The Linux install came with 3.12.

I see Tailscale is (currently) free for limited personal use. I hope they stay free, I’ve been using VNC and they are dropping the free personal account soon.