Teensy + F9P GPS + IMU Setup

Hi All,

I am new to AGOpenGPS and this is my first build. I purchased a F9P and all was well. I noticed that when I was stopped the screen would still move just a bit. I read that if I add a IMU this should reduce this. I used the image in the Autosteer build to attach a Teensy 4.1 and imu bno085. I uploaded the [Autosteer_gps_teensy_v5.ino.hex] file from
AgOpenGPS_Boards Teensy.
Once I had all of this completed, whne I connected it to AgOpenGPS nothing would work. The USB was plugged into the Teensy (I got a new Com Port from the old F9P.) In AgIO the GPS was red then green then red. It switched back and forth. The data was blank. I unplugged the Teensy and plugged the F9P in only, then the GPS started working. I checked all of the wires and they all seem to be connected properly. I can only think the Teensy program may be an issue. I read the forums but did not read anything about this.

These are connected via USB only. No UDP in my build.

simpleRTK2B (ZED-F9P)
Teensy 4.1 no Ethernet
Adafruit BNO085 (IMU)

Any help would be great.

1 Like

It could be because the F9P is not configured right on Uart1 with the right messages and baudrate.

First I must admit I use udp!
I have the same parts in one of my panda systems. I use the schematics from AIO board, where single rover f9p is connected to teensy 28 and 29 ( f9p tx1 to 28 and f9p rx1 to 29)
I am not sure if teensy program does autoswap
between rx2/tx2 (pin 7 and 8) and rx7/tx7 (pin 28 and 29)?
You only connect one usb to computer from teensy and that should give green on IMU and GPS.
Autosteer demand an autosteer board with ads 1115 (or an ads1115 connected to teensy tx4 rx4 REMEMBER level converter between ads with 5v and teensy 3.3 v

But teensy only output panda if it have a proper gps signal.
So check baudrate from f9p to teensy as noted in post above.


I’m using the same setup teensy USB, F9P and adafruit BNO085 without any issue.

The file to upload to teensy is the .ino file not the .ino.hex : https://github.com/farmerbriantee/AgOpenGPS_Boards/blob/master/TeensyModules/V2.5/Firmware/Autosteer_gps_teensy_v5/Autosteer_gps_teensy_v5.ino
Make sure to also update the F9P with the last config and firmware

Let us know the status once the teensy and F9P is updated. If it still doesn’t work, open the serial monitor in AgIO and show us the output.

Hi All,

Thanks for the. I am still having an issue. I will walk you through my steps.

  1. Updated F9p Firmware to 1.32 from the Firmware link above.
  2. Installed the Config for single antenna Rover from the link above.
    I did this in u-center by:



  1. Load the Autosteer_gps_teensy_v5.ino.hex from the Link above. Once I finished this, I went into AgIO and get this screen.

For connecting the Boards together I used the mapping in the original post. Teensy pins 18, 19 go to the IMU on the SCL and SDA pins. Teensy Pins 7,8 go to the GPS on pins Tx1 and Rx1.

For testing purpose, I decided to step back and use the Teensy for IMU only. I put the code for the USB IMU from the AgOpenGPS_Boards-master\ArduinoModules\USB\IMU_USB_v5 folder. When I do this the IMU turns green in AgIO and I can see data in the Arduino IDE.


I plug the F9P GPS directly into the Computer via USB. I get green in AgIO.

So from what I can see. The USB on the Teensy is not sending the GPS back to AgIO.

Thank you all so far. Anymore suggestions?

Power f9p on the other usb input, to make sure agio do not get gps direct from f9p.
Teensy can NOT output panda data including the gps data before baudrate on both g9p and teensy gps input is exactly the same.
You can try to match them in two ways.
Change the baud in the ino or change the f9p by ucenter.
Baud can be either 115200 or 460800 (perhaps i remember the last 3 digits wrong)
They will both work but best is to use 460800

If you upload the latest config on F9P and Teensy the baudrate should match.
However, you again said that you uploaded the .ino.hex file to Teensy, are you sure that you successfully uploaded the right code to Teensy?
Connect all the wires to the teensy and plug only the usb to teensy, then open the serial monitor in AgIO and shows us the output.

HI All,

Thank you. So I found the issue. I was using the Arduino IDE and opening the Autosteer_gps_teensy_v5.ino file and using that to upload directly into the Teensy. When I did this the GPS does not work. I used the teensyLoader and selected the already compiled hex file and the GPS now works. I redownloaded the files from GitHub - farmerbriantee/AgOpenGPS_Boards: Hardware PCB and firmware for AgOpenGPS Software and tried again. Same issue. I have it working which is great but the source code must have an issue. Is there a way to report this or have someone else verify?



Thanks everyone.

Did you install the teensyloader?

Hi Larsvest,

I used the one in the board folder. I downloaded the Arduino IDE from https://www.arduino.cc/en/software. It is version 2.0.4.


So you did install the add on as instructed from pjrc to the 2.04 after installing arduino ide from arduino

This is the tuto for uploading code to teensy.

What is not working and what bug did you found? As per your screenshot now you’re successfully getting connection from your panda setup and also receiving $panda trame, right?

Edit: you were right, he later got it working, and that is the post you refer to.
Skf now think there could be something wrong with the files, but I then suggested it might be that he is not using correct arduino ino combined with pjrc extra file.
That is why he had to use the hex file loader.

You got his info wrong. He wrote gps is only working with usb direct to aog.

Be aware: two ways to use teensy on arduino ino:
The 1.57 teensyloader together with arduino ino version 1.8.x .
Arduino ino ver 2.0.x need another way to get in contact with teensy.
Both ways are now linked to in different posts above.

NEW yesterday a teensyloader 1.58 was released.

Why is the logo green on com3 and showing $panda trame then? That couldn’t be coming from the f9p directly.
Please clarify the steps you did and what is not working. V5.7.2 and all the latest config file is working with the wiring diagram you are using.
Is your teensy blinking orange while running? Are you sure the program get sent to the teensy?

See my edit above you were right.

HI All,

I hope to make this clearer. I know it is hard when you are not here to see what I am doing. :smile:

First: My Teensy is a 4.1 without the Ethernet extender. I have one but have not soldered it onto the board. Therefore I can only test and use with the standard USB. I also updated the 1.58 Teensy files as stated above from PJRC.com. I am using AGOpenGPS V5.7.2.

How I got it working:

  1. Run the teensyLoader stored in the folder downloaded from AGOpenGPS github.

  2. Select the hex file in the same folder.

  3. The Teensy has a blinking Orange light next to the Program button.

What is not working for me:

  1. I open the Autosteer_gps_teensy_v5.ino file from the Boards folder downloaded from Github.

  2. I connect it to my Teensy.

  3. Verified my software was up to date for the teensy.

  4. I click the button to compile.

  5. The teensyLoader pops up when completed.

  6. I push the button to load the complied code. It reboots when completed and now the Teensy has no lights on it and I can hear it connecting and disconnecting from the computer over and over again.

  7. There is no lights on the Teensy. The F9p does have lights but cannot connect to it because the Teensy will not stay connected.

Thank you all. I hope this helps. I would like to be able to compile the code myself so I can add other code for a section controller possible.

1 Like

Quite confused.

What is the correct way to be uploading to the Teensy?

Check the agOpenGPS boards wiki

I followed the step by step guide on the wiki and it was spot on. Worked 1st time for me

Hello, where we can find the agOpenGPS board wiki?
Thank you