Trouble with RTK Fix

I updated to AgOpenGPS ver 5.8.3 last week and noticed I can only get Float. I switched back to ver 5.5 and everything worked fine again but forgot to close AgIO when I re-opened 5.8.3 again. With the old version of AgIO, AgOpenGPS ver 5.8.3 had RTK Fix. It does the exact same thing for AgOpenGPS ver 5.7.

Any idea why I can get RTK Fix if I use the AgIO from ver 5.5 but not 5.7 or 5.8.3?

UCenter I can get RTK Fix in less than a minute.

I am using KaupoiMod v4 board, ardusimple F9P and seperate BNO085 connected by usb. My NTRIP client is through and the base is 15km away.

How about the newest release?

What is the newest release? I thought it was ver 5.8.3 which uses the same AgIO as 5.7.

Thanks for the link. I’ll give it a try tomorrow.

Still having same problem. Everything works with old version of AgIO but not the 5.7 version.

Have you tried re-updating the GPS Receiver with the latest code? Something may have gotten changed. For sure on the GPS Receiver end.

And made sure the settings in both AgIO’s are the same?

Why is your RTK age at zero?

I’m pretty sure there was a version where you could have the wrong configuration on the receiver, and everything would work fine. But in some newer update, it would cause problems if you didn’t have the right configuration on the receiver.

I did have the Basis_Ortner on one and the Rover_AOrtner_10hz on another one and they both work the same. I recently put the rover config from ardusimple on one and nothing changed. Just found the SingleAntennaRover file and loaded it. I’ll post after testing it.

Guys I’m using a single antenna AIO v2.5 board and I think I done my best to get a tractor on the line. Next step is RTK I guess… So just for show I’m trying to connect to free rtk2go corrections…

Main questions are: Do I need to change any firmware on teensy or f9p to receive rtk or only enabling ntrip in AgIO is enough? Also I need internet on my tablet? Can it be connected to the board over udp and wifi from mobile hotspot in same time?

No, and yes, and… Yes!

1 Like

Do you know what format is needed rtk to be? Rtcm2/3?


1 Like

I have used every rover configuration I can find and still get the same results. It seems like the newer version of AgIO might be disregarding satellites closer to the horizon? If I go past the bush that is about 3 meters off the road AgIO 5.7 will drop to single GPS then eventually recover to float… I guess I will keep using the old AgIO.

AgIO does not calculate the RTK fix. The calculation is done on the GPS module. AgIO transports the correction data to the GPS. It is really just a data broker.

1 Like

If I start with the old version of AgIO, AgOpen will have RTK Fix. If I close the old AgIO and start the ver 5.7, Agopen will have RTK for about 30 seconds then switch to float and never switch back to RTK. I don’t move or anything. Same ports, same speed. The only thing I change is the version of AgIO.

Can you take picture of ntrip configuration in both version?

Compare your NTRIP settings like @tuzlian mentioned. Depending on how old the “old” version is, you might be able to save the AgIO settings from the old one and load those into the new one. You might also be able to expand the AgIO window to see what RTCM msgs it’s receiving from your NTRIP connection (give it a few seconds to populate the list).

1 Like

Tried again today and had an awful time getting everything connected. Finally got everything connected and had full RTK on every version of AgOpen and it worked good for over an hour. I thought something must have sorted itself out until I restarted the everything. If I change to old AgIO, I have RTK in about 15-20 seconds.

I saved the config from the old version and loaded it in the new one and instantly have RTK. I have no idea what it changed but for now, it’s working. Tomorrow is a new day. Thanks to everybody who chipped in especially m_elias who thought of saving the config.

1 Like