Trouble with steering motor control

Hi everyone!
I’ve got trouble with the steering motor control when connecting the gps-antenna and the arduino to the tablet.
The steering motor control does a good work and follows the set pont line in a good way if I disconnect the antenna and use the simulatior.
Using simulator:

Connecting the ublox antenna and the arduino with usb to the tablet:

Here the things I’m using:

  • Windows 10 on a Acer tablet
  • AOG Version 4.3.10
  • Arduino nano
  • ibt2 and 24V
  • ublox f9p antenna (ardusimple starter kit)
  • RTK correction with NTRIP (hotspot with Smartphone)
  • arduino and antenna connected with a USB 2.0 hub to the tablet

Here the things I have already tried:

  • another Laptop without USB hub
  • USB 3.1
  • USB hub 3.1

I have found nothing to fix this problem in the agopengps discourse, YouTube or in the internet. Hope it’s only a very stupid mistake and easily can be fixed.
Hope you guys can help me with this problem.


how it works with manual drive mode?

In both graphs I am using the manual drive mode for the steering motor when the tractor is not moving.

It seems like the tablet can communicate with the arduino or the antenna.

Do you have PCB or do you connect with cables?

I’ve connected with cables.
What could be wrong?

So you power everything from USB. Maybe there is too much load, try to power the arduino from outside.

Do you drive faster than the minimum speed (normally set at 1 km /h)

I’ve forgotten to say that I’ve also tried several usb driver. Now I’m using the sparkfun ch340 for the arduino and the original driver for ublox.

I have connected the arduino with 5V-in and ground from the tractor.
The ublox module I have only connected with the usb.

@baraki: do you mean that I should power the ublox module with 5V?

@Larsvest: unfortunately it’s the same while driving faster than the minimum speed or standing.

At what rate (Hz) is your f9p outputting NMEA?

@Kaupoi: do you mean the rate I can choose in the AOG settings? 10 Hz

No. I mean the rate you’ve set to f9p with Ucenter.
Could you take a photo at fullscreen aog when using f9p?

I will send the photo on tuesday, because i’m off the farm until then.

be sure to follow this setup and upload this config file in the ublox device

Ublox F9P - Config for rover

Thank you very much. Somewhere there was a mistake in the u-blox settings. Now it works.