Troubleshooting steer motor not moving

As far as I know, I have all my hardware and software set up. In the upper left hand corner there is a bar (labeled “steer”) that turns green as you get stuff working and set up right. Mine hasn’t progressed very far, so I guess I’m looking for more info about what exact steps are required for my steering to start working.

More info: I have my boundary and set and an AB line, but the steering motor doesn’t turn. I push the autosteer button and it turns off after a couple seconds. What should I do or check now?

Edit: the steering motor will move if I push either of the buttons on the motor controller.

Do you have a switch or wire that pulls steer pin low? Connect middle pin of steer connector on PCB to GND. Does motor run when you are doing the settings as in Brian’s video?

1 Like

Do you have a pic of your PCB setup available?? Should be able to run the motor in the Steer Config settings using the Drive feature first.

I had exactly the same problem. It’s because you have autosteer turned off in the steering settings.

I don’t have AOG in front of me right now, but check the tabs in the autosteer config until you see the autosteer icon and turn this off. That should fix things.

Are you talking about the vehicle settings under the guidance tab? There is a button that is greyed out and labeled “auto / manual autosteer Btn” when I click it it turns green and says auto. Won’t be in the tractor until tomorrow but l sure hope that fixes my problem. I didn’t know there was an option in the vehicle set up tabs to click.

Yep, that sounds like it. I’ll fire my rig up tonight and confirm.

image
Here is a picture of my pcb. I tried the button on the vehicle setup and it was already selected.

How is the loop wire on the steer switch connector wired? Looks like the loop is from +V to Steer signal. If so, isn’t this equal to “Auto-steer off state”?

1 Like

Looks like maybe your STEER switch is wired wrong…Mine is hooked up 0 terminal through the switch then back to COM terminal… So if you short out 0 to COM that activates the motor controller. I dont believe I used the V terminal. Make sure you select the Momentary or Switch in the INO based on what type of switch you are using…Someone can confirm this for me…

image

1 Like

You are correct his wire must go from O to COM (remember COM= GND, so do not connect + to COM)
Brettb has left the SwitchOrButtonsetting in the INO at 0 (for switch) because the problem with not being able to activate autosteer, does not happen when 1 (for button) is selected.
So this sentence (which tells about NANO pin) “// Button/switch pulls pin low to activate” , could have added this info: On PCB connect steer switch O to COM to activate.

1 Like

I finally got it working. It was the steer switch wiring that fixed it. Thanks!

3 Likes

Heh, that switch eh? :slight_smile:

That’s what threw me here, I had the same when autosteer was disabled on that tab. Is the problem here that the autosteer switch is set to default OFF and so AOG disables the function in software?

If you don’t use a switch, and tick on the software-autosteer button, the hardware should also follow. AFAIK

20200913_223225 I cannot seem to get the steer motor to turn in the “Auto Steer Configuration”. I seem to be having a similar problem to Brettb however I think my switch is wired correctly (Autosteer switch moves from 5 to 7 in config). The WAS is responding (steer chart) and if I push the buttons on the Cytron they move the motor both directions. They just don’t seem to work together.

The steer motor does not turn when I choose “Drive” in the “Auto Steer Configuration” when I move the arrows left and right.

Vehicle Guidance is set to Manual.

Any suggestions?

Have you changed the gain settings in auto steer config? Default settings are at zero.
and WAS cant be at end of stroke or it shuts motor off.

AOG drive
Maybe if you post a picture like this can help to solve.

Do you have two green “dots” at the bottom right. One blurred green dot and green inside steering wheel?

Your steering wheel would have an M (manual) beside it where mine has R

But I think you should set it to Remote like mine because you have a switch connected.

It is not the WAS itself but the max steering angle you set.
It is possible to set eg. 45 degree as max steering angle, but if the Was (with the decided counts pr degree etc. ) only goes to 40 degree when it has passed its end of measurement, then the motor will continue to run. (would happen in U-turn)

I use that max steer angle setting to. But I think Brian set it up so if WAS arm broke and would go to end of stroke the steer motor would shutoff. A safety feature. At least that is how mine works. So when testing i would have to move WAS arm a little for motor to go on.

Thank you for the suggestions. My WAS was at the max and my gain was at 0. I will be back at this project tomorrow and will try again. This has been an interesting project. Have a great day.

Tonight I returned to this project and your suggestions worked. I think it was the wheel angle sensor as I moved the sensor inside 45 degrees and it worked.

Now all I have to do is learn how to set up fields.

Thanks for your help.

1 Like