Ublox F9P - Firmware programming

I am continuing to work on my project to build Panda with my micro F9P.
I received my micro F9P and started to follow tutorial to configure it.
It seems that I am blocked at the first step as I can’t send firmware.
I connected the micro F9P to my laptop, and it seems to be well recognized
But when I start the Firmware update tool it seems nothing happen, it stops after 4-5 seconds.
I have tried to use the Legacy Firmware update tool as well, and I get error message “Binary prefix error, image invalid.”
I have tried different baud rate, downloaded several time the binary file form AOG github and from Ublox website, but I dont’t find the solution.
If anyone understand what I am doing wrong it would be really helpful.

Have you found and read this thread as it sounds very similar.
Think the solution was it needed to be connected to 12v via the pcb.

Thank you for your quick reply !
Yes I found this thread few days ago, and it was also looking similar. But the differences are that I am not using AIO board to program it.
I am using xbee adapter to USB. So I am not connected on 12V
I have the green led in the bottom right flashing on my Ucenter software, so I don’t think it is a connection problem. My COM port is appearing and disappearing when I connect and disconnect the F9P on my laptop, so it seems good.
It really seems that the Ucenter software is doing nothing, not even trying to send the firmware, as I get the error in the legacy firmware update tool immediately after I press the ok button.

So you are connected.
But why not just skip firmware update as I suppose f9p come with that 1.32 firmware installed already.
EDIT: If someone read this later, it seems the F9P comes with 1.13, so use the 1.13 config, as posted next.
So just upload the 1.32 config file. (If firmware does not match, then u-center will protest😃
Firmware update/downgrade would be needed if you want to use 1.13 config.
Also note f9p is generation 9

The new F9P you get from ardus. has firmware 1.13, just use 1.13 configuration files. I don’t know why but some computers with WIN 10 don’t want to install firmware on f9p so you can also have a problem with this even if you choose the right generation.

1.32 was produced for surveying. It has no improvement for aog. Just leave the f9p as it comes with 1.13 and it will perform great without a bunch of extra code running from 1.32.

Thank you for your answer all!
On your advice I tried to send the config file, but this as well doesn’t work.
I cheked the firmware version with View - message view - UBX - MON - VER and it seems that you were right my F9P is already programmed wit the 1.13 firmware.
So I tried to send the 1.13 config file “Rover_AOrtner_10Hz-01.txt” but I get timeout error.

Are you able to modify values, without loading a configuration file. Just try to change a parameter and save it?

I use this setup, and to connect I had to use Automauding then I got connected at 38400 baud to u-center

Thank you! I used 38400 baud rate and it worked. So I could update the firmware and send configuration file. Ok sometimes it was failing, but I tried several times with this baud rate and at the end it worked fine. Thank you for your help to all.