Problem while configuring F9P

i’m trying to get the firmware on the F9P but i run into a problem.
I have connect the micro to the computer with USB. in U-center is says connected. however when i want to upload the firmware the “Go” button stays grayed out. please see screenshot below. I’ve tried multiple USB cables, im using U-center 22.07.

Did you try baud 115200?? Also leave the ticks empty

It appears whatever port you are using is not the correct port and/or software configuration. As I can see on the right hand side, there is no GPS data coming in that would be a F9P.

Are you sure you installed all required drivers?

Double check the port number using the Windows hardware manager of your choice.

Furthermore, you are using a u-blox 5 hardware setting, it should be u-blox Generation 9. See Receiver>Generation


Windows 10 should connect without specific drivers
are you sure no other software has the GPS COM port in use? (like agio)
also disable the ¨enter safeboot¨ and “send training” options

Hello, I upgraded de firmware (version 1.13 on a new ZED-F9P)to a newer version, recommended by Ardusimple. Everething going well til the end, its look the program has stopped/crasht . So now i think i lost the Firmware and have no more connection with the F9P board. Is there a solution? Thanks

No response after powercycling and reconnecting? Check the Ardusimple recovery pages

Is ucenter set to autobaud ?
F9p could just have changed baudrate.

Thanks for all your quick replies! this forum really gives me the confidence that eventually i will get this working.

i’m making progress but it’s running yet. Main thing that worked was setting the generation of the receiver to gen 9 that made the “GO” button green. but now it will freeze U-Center during the process.
I’ve tried with baudrate 460800 and 115200 both do the same. I’ve unchecked the ticks. I’m running windows 10. As far as i can find there is no other software on the COM port.

the connection symbol in the bottem right isn’t flashing green as was suggested it should in this part of the forum: F9P firmware update and config files could that indicate that the connection is still not good?

First you need to be sure to have a working connection with the module. The LED in the bottom bar will be blinking green. Opening one of the consoles on the View menu will also show if its working.

Do you hear Windows beep when connecting/disconnecting the USB cable? Make sure you have a working USB cable (many of them are charge-only)

Still no go? Next step would be trying the UART hack as described om the Ardusimple forum

1 Like

Thanks to all ! problem solved ! with the Ardusimple recovery pages recommended by SjaakA

think the problem is indeed the connection. strange thing is, when i connect the F9P to the computer it only sounds the “usb disconnect sound” and not the “connect sound” before it. sometimes it doesn’t make a connection sound at all, so think the problem lies there.

i’ve looked at the UART hack on the Ardusimple forum but I have a micro and not a standard F9P so cant really figure out how to do the hack and do the bridge wire needed.

Think i’ll contact Ardusimple aswell.

I had some problems and sent them a mail, they are very friendly and will help you for sure… usually sellers don’t care :wink: :+1:

Yeah must be in the F9P, tried different laptop aswell now, with multiple USB cables, nothing, not even a connection sound, there was 5v on the pin 6 so there was power. In the proces almost tore a usb port of the pbc so today wasnt the best day lol. I’ll contact Ardusimple.

If you go to the device manager in windows and plug and unplug it. Does anything show up? If it shows up and an antenna hardware or receiver hardware leave it plugged in and delete the hardware. Then it will show as a com port.

I had problems connecting to in u-center but when I in the receiver settings those u-blox Generation 9, and choose Autobauding I got connected, it connected at 38400

still no succes. i tried the autobaud, that didn’t do it.
contacted Ardusimple, first check check they proposed (maybe someone in the future finds it helpfull) remove the Teensy as it might interfere with the F9P, but had no Teensy on the board.
next step they gave me is to use a TTL-USB connector and connect to the UART straight away and then configure it.
I’ve ordered a converter so we will see then.

Which micro are we talking about?
Micro PCB
or Ardusimple f9p micro?

Post a picture of what you have! because your last post about TTL USB points to different problems.

If we are talking about Micro PCB then use the other slot for f9p micro (and then the other usb socket for it too)
Other people have experienced problems with the soldering of USB sockets on micro PCB
Edit: after configuring F9P, then move it to correct socket again.

That maybe explains why i only hear the disconnect sound? The USB connectors seem to wiggle a bit indeed altho i’ve already tried 5 different positions now on my 5 pcb’s

So no 12V to the board, no fuse, no current sensor installed on this board yet

Just micro F9P on the V4 all in one micro board, with USB cable.

Did you try my suggestion? @EFlonk

yes i did, i didn’t see anything change. When the USB disconnect sound was heard the list would refresh but nothing changed.