V 5.2.2 Bugs - You find em, We fix em

Less and less problems for sure, but always little improvements for sure. Find something broken? Please post here.


It appears when we want to use the keyboard. I noticed that a lot of people have a problem with this.

Of course it works for me :frowning:

tractor air conditioner is required. tablet slows down due to heat. It goes from 2 3 cm to 4 5 cm error.

3 Likes

When I have WORK switch input set to manual and go look at the setting, it shows this:

Then if I un-select “Switch Controls Auto Section”, save/close, and open the settings again it shows this and my work switch controls auto.

I find it confusing. Why is the text changing? It would make sense to me if the text always stayed as “Switch Controls Manual Section”. Then when it’s selected it’s manual and un-selected it’s auto.

Edit
Or have a manual & auto button under the heading “Switch Controls”, selection should then be obvious.

Not so much a bug, maybe a feature request.

I’d like to see all parameters that might be changed while tuning the steering characteristics to be put in the Auto Steer Configuration window to eliminate the wild swinging reset when changing something like fix to fix distance, IMU GPS fusion or IMU filter etc. Or maybe the reset can be eliminated, I even like to adjust U-turn settings while autosteering.

This popped up yesterday. I was flipping through and changing the settings for tractor & tool. I didn’t try to replicate it as closing and relaunching AoG seems to have fixed it but maybe there’s a clue in the message.

I found a solution to the problem with the keyboard not working!
I was looking for the cause for many hours and the solution turned out to be simple:
It is enough to install version 5.1.4 and run 1 time, each subsequent version, including 5.2.2, which had problems, works fine.

1 Like

Is it possible to make sure autosteer is off (both remote and manual) when changing settings so that it doesn’t go crazy with autosteer on while AoG resets it’s internal data/variables? Maybe another reason to figure out a way to avoid the crazy data reset.

The back story: I’ve been having Nano USB issues, it’s usually solved by swapping ports on the usb hub and connecting AgIO to the new com#. Then it works for an unpredictable amount of time before there’s a pop-up msg about a connected device not working. I usually operate my autosteer on/off via remote button but when it malfunctions and I don’t have time to swap usb ports I steer manually and change the autosteer on/off to manual (on screen touch). Once, after fixing the com port issue, I forgot to change the autosteer on/off back to remote mode before I pressed my button to turn autosteer on. Then realizing my mistake, I changed the setting and as soon as I okay’d the changes AoG went crazy like usual (until it processed two good data points and figured out it’s position again) but this time it also immediately activated autosteer and tried to steer hard right. I’m thinking the Arduino was reporting “autosteer on” state because I had pressed my button while in manual mode.

I’ve started coming to a full stop before using any menu settings. When the steer indicator in the bottom left is red you know auto steer is disabled.

Some of the values in the menu cannot be changed on the fly due to the data having to be pushed to the nano. Leaving the menu I think also refreshes the PC values as well, somehow at this moment the BNO or its comms resets causing the spinning havoc.

Turning on manual section while in Contour mode causes it to lose its current contour line, and stops looking for a line for a few seconds.

i have a problem with 5.2.2. my antenna is bd980 my computer Panasonic cf-h2. when i drive in one direction, on the screen the line changes in all directions. and the area and the displayed machined area is far away from the reality. Example: i drive 20 meters and the display show 0,2 ha. the with of the machine is 2 meter. What is the problem? with other programm, like qgis is all perfekt. so i think there is no problem with the antenna or rtk signal. i have tested another tablet but it is the same.

hello Iam a new user of 5.2.2 version , before I used 4.3.10, I had a probleme may be I make a mistake . When I am on a bordury of a fiel if my tool go outiside of few cemtimerter of the fiels , AOG stop to ad worked surface https://onedrive.live.com/?cid=38C9492DA11A24B2&id=38C9492DA11A24B2!30634&parId=38C9492DA11A24B2!267&o=OneUp

Hello again , always new on 5.2.2 , before when I used "drive in " AOG choose tthe right field where I was , but I think 5.2.2 it not able to do that ,I saw that with old version of field register with 4.3.10 , but I created a new field with 5.2.2 , I had the same problem. I am right ? https://onedrive.live.com/?cid=38C9492DA11A24B2&id=38C9492DA11A24B2!30631&parId=38C9492DA11A24B2!267&o=OneUp

Had some issues with AgIO hanging recently.
A couple of fields lose 4G connection at one end, but when reconnecting halfway back the field AgIO will hang for a few seconds, just enough to cause AOG to become ‘lost’.
I’ve played around with it a bit more since, and it seems to be on a network change (i.e. from wifi to 4G, or no network to 4G).

Also I came across an unhandled exception with u-turn, but this was probably because I messed around with the boundary file. I recorded my outer boundary after my inner boundary, then re-ordered the file so the outer comes first. I assume I need to reverse the order of the points though, as things like Headland and outer Tramline are now on the outside of the field.

Perhaps a useful feature could be to specify when recording whether it’s an inner or outer boundary? I’ve been changing the shapes of my fields to exactly line up with tramlines so they are easier to work, but in doing so I had co-dependencies between inner and outer boundaries (recording my inner so I could get an AB to drive my outer, etc), so it would be nice to record them in any order instead of having to do outer first.

Do you use NTRIP client in AOG?

If so its probably that… Ive had this issue since 4.3, and it still happens now, I just use STRSVR instead, it seems to do it as you say when connection is lost / changes, which happens alot for me in the hills around here, and it will just lock up the ntrip client for few seconds… Have mensioned it before but seemed like I was the only person having the issue at the time…

Yes, should’ve been more clear this is the Ntrip client causing the hang on network change.
Back in the v3 and v4 days, it would hang every time it was waiting for a connection, so quite often. AgIO is certainly much better in this regard except for this one edge case

Could this be due to the long connection 12second countdown in agIO?

Everytime the link is disrupted… 12, 11, 10, 9, 8…3, 2, 1.

This could be shortened to 3s?.

Anyone got a handle on having to “set forward direction” after every three point turn, reverse, or setting change. Is the program expecting certain fixed direction for the bno, is there a way to software lock it? or to make the program know when you are straight online to auto reset? did not notice it in 5.2.1. but its pretty regular in 5.2.2?

It happens pretty much every settings change unless you are doing a fair speed, then it seems to cope with just a hiccup.
Lengthening the start speed helps a lot with the 3 point turn issue, but it still happens.

If you use a very short fix to fix it does it randomly on rough ground too I found out.

I could cope absolutely fine without the whole reverse thing but with heavy IMU heading bias it takes forever to recover from a reverse manoeuvre. Heavy IMU bias is miles better on rougher ground.

Anyone able to point me to the GPS/IMU heading fusion algorithm in AOG source code? I get lost in the mire of bloody winforms but want to take a look.

Just to iron out some terminology.

Start Speed is the speed that ??? begins to happen.

Fix to Fix length is the distance of ???.

I am confused because to me fix is when the RTK has completed fixing ambiguities and remains, unsure how it got a length.

Also wondering about degrees per degree of sidehill, whats a decent value?

I thought this would just be a fixed calculation of antenna height vs roll degrees.

Trying to squeeze every mm out of this system.