V4 all-in-one PCB

Do you get any response from the motor when you press the ma and mb buttons on the cytron?
This would comfirm the motor and wiring to it is fine.
Try taking the relay out of the mix and connect the motor wires to the ampseal bypassing the relay see if you get any motor response from the drive function then

No response at all when pushing those buttons. Think i’ll try to put power to the motor directely tonight to rule out the motor. Resoldered the teensy to rule out a failed solderjoint, already prepearing a new pcb to switch that out too.

If you get nothing when pressing those buttons then it’s almost certainly the cytron or down stream of it, the motor.

You jumpered a wire to select power input for the cytron, yes? It has a green light on it?

If it worked with the laptop but stopped working when switching to tablet, I would retry the laptop to see if it works again.

If so it’s likely a software issue rather than hardware.

Thanks for all the replies. @TeddyStamford, yesterday i swithed back to the laptor, used different ethernet cable and so on, no effect. So I put 24V directly to the motor, that works, so the motor is OK. then put 24V on the ends of the wiring, was also OK, so from 23P to motor is OK.
next i switched the complete PCB, resoldered the teensy just in case there is a faulty solderjoint, reflashed the teensy (again), put a cytron on and it responded to the MA and MB buttons!
after that swithced back to the original PCB and it also worked.
then switched to the different cytron that i have and it failed, so I think thats the issue.
How ever, after that I put the first cytron back on and it started showing the same problems again. After that started it all up again with turning tractor and everything off, and its working again… so not completely confident but for now it seems like it’s working.
@andyinv, Cytron was showing a green light the entire time.
Few questions i have tho are:

the second cytron has the free wheel mod on it, with this Cytron it won’t respont to MA and MB button inputs, could de mod have this effect? or is the cytron most likely toast?
can you test the Cytron in any way?
can you change out the cytron after just cutting the 12V to the PCB, or should AGO restart too? (this might explain why the problem started playing up again the second time.
Strange that it suddenly broke, I’ve maybe used it 15 minutes.

The ma and mb buttons no longer work if the cytron has the freewheel mod done

1 Like

I have a Baraki hydraulic valve and I can’t turn the steering wheel when I activate the auto steering. Currently, the settings are as in the photo. I read on the forum that Baraki had different sensors and something needs to be changed in the Autosteer.ino file. I just need to add an exclamation mark (true, false)?


See if the switch is normally open or normally closed with a multimeter, if you have one. I think normally closed needs the !, but I could be mixed up.

If you got the valve recently, you need to use the pressure turn sensor.

Pin 10 and Pin 23 ground are closed all the time when the steering is on, the sensor circuit is open when turning the steering wheel. So the sensor reacts, open-close. Tried with and without the 505 line “exclamation mark”, no result. I also tried turning on the pressure sensor and changing the percentages, no change.

How does your button work (should be ONLY ON, as long you press finger on it. Meaning a short press is enough to engage, and another short press will disengage autosteer)
Also I don´t think you should change anything in the INO manually, it happens when you click “Send Save” (but of course only if teensy is connected to computer when doing so)
Brian made an instruction video some time ago. (Send Save is around 1:30)

The button works as you wrote, the button without fixation. Of course, I press save every time after making changes. Surface 5 connected to v4.1 board with USB to LAN adapter cable. Making any changes and saving both “Turn sensor” and “Pressure turn sensor” does not change anything.



Did you set the jumper as said on wiki?


Got wrong link at first!

1 Like

Are not. I will try to find such a part.

If you don´t have one at hand (could be from old computer or other pcb) then form a ring of a piece of wire that fit around the two pins, and squeeze tight with a pair of pliers

on the v4.1 board there are two variants, “pressure” and “remote”. It didn’t work for me under “pressure”. On the second variant “remote” works with unit “1”.
I make sure again that you are the master. Thank you.

1 Like

I will write here, I didn’t want to start a new topic. A friend has a Muller TRACK-Guide III monitor with section controls. Can Baraki hydraulic valves be connected? Is there a thread about this somewhere?
Cytron could be used for hydraulic valve control.
How to adjust valve operation, sensitivity, speed?
There is no such option on the Muller computer. I found out that you need a Muller box (~3000e), then you can do steering control and settings through the browser.

yes thanks

Hi - if I use a button connected to ampseal pin 8 and to gnd is this meant to update the screen steering status from green to red and vice versa ? I would be doing this in conjunction with a relay on ampseal 7 to disconnect the steering motor. Thanks in advance.