V5.5 panda

Hi there I’m putting together a single antenna improvements v5.5 with the teensy 4.1 and BN0085
But have looked but cant find anywhere that showed how to configure the teensy 4.1 for agopen gps the f9p is configured and has rtk was well.
I have downloaded this program (Arduino 1.8.16 Teensyduino)
and tried but doesn’t seems to be working can anyone help.
Was well doo we run 2 usbs one from the f9p and one from the teensy4.1?

Hello Renato!
Do you have a PCB or are you connecting the parts with separate wires? Check out my post, are you building the same setup? https://discourse.agopengps.com/t/basic-panda/11082?u=16759

If you use ethernet to connect the Tennsy 4.1 to the tablet/PC you can do what I did and use tag/5.6.33 SupportFiles.zip succesfully the other day. In the SupportFile folder \TeensyModules\Firmware\Autosteer_gps_teensy_v5_5 you find Autosteer_gps_teensy_v5_5.ino. Upload this to the Teensy.

1 usb to the Teensy is enough to power both the Tennsy and the F9P if you have the same connection setup as in the post I linked, but you can use both.

Have you already configured the F9P?

its with wires but i want o weld it to a pcb but want to make sure it works first
and it will have to be conected by usb
the f9p has been configured and it wors by it self
but i dont know how to programe the teensy 4.1

first is first

i have followed the instruction but stil can see the f9p neather on agopen gps or u-center

I had the same problem when connecting my set “as someone wrote above, the problem is the incorrect settings of the GPS module have been uploaded” I am not able to tell you what settings you should upload because I do not know from the fact that you have an Xbee communicator connected to the module, bat from the diagram shows that you have not connected 3v to the GPS module

yeaah you rigth there was a conecting missing but still doenst work

What is the speed on uart1 and uart2 f9p?

Which version? 5.6.6 onwards, the speed to uart is 460800. And the messages to be sent to uart 1 and uart 2 must be reviewed. uart1, usb= VTG, GGA.

Its v5.5

will try the settings anyway to see if works

try to change settings of UART 2

Where is the 3 3 v ioref between teensy and F9P?
I would prefer feeding bno085 with 3.3v instead of 5v

i manege to make it wor it was the f9p confic that was wrong

And where was the mistake?

dont know i just downloaded the suport files from 16759 and did a reciver config and it worked

1 Like