WAS not working

Hi there, I’m currently bench testing my setup, but I’ve had some problems with the WAS. I’ve tried 3 different WAS and all of them have not worked. I’m using just the simple discovery 2 suspension height sensor and I’ve test the voltages and it’s getting 5v but when I move the WAS the voltage doesn’t vary meaning AOG thinks it’s not moving.

If anyone can help me here it would be much appreciated!

Thank you

Was the ads1115 installed on your pcb by jlcpcb?
Mine wasn’t installed so had to add the surface mounted module
Put up a picture of your pcb aswell perhaps
Do you have the was wired up correctly on the ampseal plug

I didn’t order/make the PCB I bought it off someone but I’ve been told to check that I didn’t have the ADS1115 on my board which I don’t. I’ve checked that the pins are wired up correctly multiple times and all seems good.

Strange Innit! It was me that assembled the board, and it was tested before posting, all working with an LR sensor.
What’s strange is that you’re not getting any voltage change when the sensor is moving. Where are you measuring the voltages? You should have 5v between red & black and a varying voltage between blue and black at the sensor connector plug.
The board provides the 5v on ampseal pin 1 so that bit is working then measures the sensor voltage on ampseal pin 2.
Really odd you’d have 3 duff was sensors in a row though!

What does your multi meter show. Skip the board for now. Verify the wiring on the sensor with a multi meter.

This video helped me a lot when i was doing mine.

Like others say test the sensor with a multi meter. It is easiest if you have a bench power supply. +5v to red wire, ground to black (It was actually yellow on my plug) and test volts between blue and ground.

Also maybe check continuity on your wiring harness. Seems odd you would get three bad sensors in a row.

Also maybe you caught this already but if you are using a single zed-f9p it goes in the left (rover) position. (edit: I have been informed they can go on either side but most people do it like you have.)

Good luck

Theres another thread where someone has the same sensor but the wires into the sensor plug are in different pins so possibly check that

The Wiki says that a single f9p goes on the right (moving base) position?

Wow. You are right. It does say that. I always put them in the rover side and they work. I need to investigate this farther.

It works both sides for single, but most people put it as pictures on the right.

For dual its important they are the correct sides with different config files.


Awesome. I’m not sure why I was so certain it went on that way.