Wheel angle sensor not recognize

i have a little mistake my WAS is on place and connect but i don’t see it on ago.
if someone can tell me why…
thanks Michel

What was are you using and how connected?

I use RTY060 connected to PCB Kaupoi v4 but maybe i use too fine cables (0.5 mm2) long of 3.5 meters.
must i have to change us by 1.5 mm2?

I think your cable cross-section size is appropriate, the important thing is that the cable is shielded so that it is not affected by external factors (interference-electrical noise).


Rty come in two versions. One for US one for EU
Which one did you get?
See rty spec for pinout, there are two different!
You can tell by the last letter in rty name.
And did you get a hi or lo type ? Lo is 5V hi is minimum 10V
If you write full rty name here we can help.

Did you do table test with it to know that it works? (Confirmed that its not software issue, right ino uploaded cables connected to correct places etc.)

That is a RTY060LVNAX low voltage 5v and connected north america pin 1 to 5v pin 2 to gnd and pin 3 to output

like on notice; but cable is not shielded
I test RTY on table that works but without connect it to PCB …
i will try tomorrow afternoon to see if 5v is on RTY maybe i miss a connection.
I choose RTY060 for disponibility and my rover turn on max 29° left and 29° right and if i understood we must have a minimum difference between WAS and real angle of direction.
We will see tomorrow…
Thanks to all of you Michel

I use rty, 70 degrees. Work well without shielded cable.

I check voltage on RTY 5v is on pin 1 grd is on pin 2 ans output on pin 3.
I control that i have 5v on PCB slot ans 2,5v on output (high on PCB slot) . But wheels and barlights on agio don’t move.
R8 is empty on my PCB may i put a wire?
I don’t want to smoke…
Have a good day michel

So the 2.5 V change (between 0.5 and 4.5 v)when you turn the wheels?
Means rty is okay.
Did you click send in AOG setup from AOG to arduino?

RTY is ok
How can i send in AOG setup?

When you are in AOG settings screen, you see a button named send.
Click HELP in AOG and you get the manual file.
You can also find manual.pdf in AOG program folder. Office 365 can translate to your language, and even keep diagrams in place.
Other programs can translate, but not all keep the setup correct.
But I think French is already in program folder.

i have just read one more time the french manual and i saw that the indicator of steering module is pink that seems it is not connected.
i have also send config to arduino; i’m sure that i made a mistake on config or a wire witch i didn’t connect.
i will make some test on table this afternoon.
The difficult thing is the 2 wheel motors are on my rovers i will try to disconnect MD13 S and ADS 712 to see if i could have WAS…
have a good day Michel

I have check connections , disconnect MD13 S ag open didn’t see WAS; i join us a picture of my PCB

if you want some zoom of pcb i will take other pictures.
thanks for your help

AOG can not send anything to arduino before arduino is connected via/in AGIO (AOG actually say it does send, EVEN when nothing happens)

So You first have send the correct ino file to arduino, using the program Arduino IDE https://www.arduino.cc/en/software (Filename Autosteer_USB_Vxxx.INO)
Or did you use the XLoader (program/sketch) found in support files?

i use program Arduino IDE
Perhaps should i do it again or how can i see what filename is on .ino

In support files. Here I have old V5 support files. I think Latest AOG download only work for UDP but check on discourse which Version does USB

normaly i have also support files . i download V5.5.
I can try to download it once again?

if you can tell me a many files shoold be on .INO
It seems to be only one file on my .INO
in your supportfiles did you send the 3 files with logo arduino?

I can check on computer later this weekend. But I am sure only difference for your version is the 5_5 instead of 5_0
Edit 17 aug 2022: For ver 5.62 I still see USB is using Autosteer_USB_v5.0.ino

What you see on my screenshot is neccessary for autosteer to upload correct to nano

Pid.ino and relays.ino are needed.