Where to begin with using the Rate Control App

I am using this system as a single section. I have a Raven 3 pin flow meter, an ACE pwm controlled hydraulic pump, with a bypass control valve. I am using an early version of the RC_8 board with an Arduino Nano Every.

As far as I can tell my Cytron is good, my Nano is powered correctly and my board is wired correctly. I will take a picture of the box tomorrow.

There are two wired coming from the pump. I have them wired to MA and MB on the Cytron and the flowmeter wired according to the diagram. I am just not sure how this should start to behave when I power the box and open the app. So far I have the pump acting like a manual pump with liquid flowing, but no matter what I do with with the box powered and the app on it doesnt seem to affect anything.

This is what I see when I open the app and pressure the pump up. I don’t see any data coming from the flow meter. Where can I view this?

Do I have my settings correct? This is what it looks like with pump running at 25psi and liquid flowing. I don’t have a fan, its a hydraulic pump should I set something different?

The module is not connected. The header for UAN is red. If connected it would be green. Go to module config in the menu and upload the correct firmware to the module. If connecting over ethernet make sure it is on the same subnet. This can also be done on the module config page.

1 Like

Thank you so much! I will reconfigure accordingly.

I sent the module config file here for RC 8. But Im not using a relay board. This shouldnt matter right?

I also sent the correct subnet, at least I think I did.

Is there something I am not doing to connect to the module?

I wanted to double check my hardware to make sure that was not the issue. I am almost certain it is settings issue. If I am on the same subnet as AOG and communicating with with the teensy (v4.4 board) then I should see be able to connect to the Arduino (RC8) right? Is there something I have to do to make it connect?

I’ve switched out my Arduino and Ethernet hat. I am running all connections through a NETGEAR unmanaged switch.

ethernet switch

It is showing traffic coming from the module at the switch. I even bypassed the RJ45 panel mount to make sure that wasn’t the problem. I used the PCB SetupApp to install firmware. It looks like all my hardware is good to go as far as I can tell. I have AGIO and AOG running while running the app as well. I have a RTK fix and my AOG board seems to be communicating over UDP just fine.

Could my there be some other setting in windows not allowing me to connect?

Should I try the Wemos D1? I was trying not to overcomplicate things for myself. I just don’t understand what else I am not doing.

Thank you so much for all of your help!

A relay board is not necessary. If the rate module is on the same subnet as AOG the rate app should be able to connect to it. I wouldn’t try the wemos right now. Here are some setup videos.
Rate Setup.zip (4.3 MB)

Thanks for the advice and videos!. When I upload the firmware to my nano, it is telling me that there is no ethernet controller present.

Are the lights flashing on the ethernet shield?

@gpierce720 had bad Ethernet adapters. Made it a pain for him. May try another, or some other sort of test.

They are both on. Do you think it is a bad Ethernet shield?

Definitely something to check if you have one that you know is good! I had lights and could even find the module in the AGIo ethernet monitor but could never get an alive status till I switched shields.

Thanks for the input! I’ve only got two and I think they might both be bad. I’ve tried my other ethernet adapter. I get one light, the green one and it appears to try to start an I.P connection, but it never does anything.

Here is the message I get now. I will be ordering some more ethernet adapters.

Any chance your ethernet shield is installed 180 degrees out? The usb on the nano should come out one end, and the ethernet cable should come out the other. Hard to see in the video.

1 Like

I had a set of 3 and they were all junk…tried to fix them but had no luck :man_shrugging:

This is how I have it installed in the rig.

Thanks guys! I was unable to find any more of the ENC28J60, with Nano form factor domesticly. I have some ordered but it could be up to 2 weeks before I see them.

I really need to get my rig going in the mean time. What is the fastest/easiest way to get the arduino talking to my computer? I would rather go wired as I have already run all the cables, but I do have a wemos. Can I use the Wemos connection to wire in a udp adapter? I also have the following to work with:

A regular Nano, a Nano every without pins soldered yet

An Arduino MKR Ethernet Shied

A different form factor ENC28J60

A Wemos D1 module.

Dupont wires

I have breadboards that will be here tomorrow.


There is example code in the ide that could test whether the ethernet shield is working. The ethernet cable has to be plugged in to test.

testDHCP.ino (1.0 KB)

Im going to assume this means it doesnt work?

It means the library is not installed. Go to tools/manage libraries to install it. Search for ethercard.

okay, got it to upload. How do I run the program? Please forgive my lack of knowledge.