Xbee LR and ardusimplertk2b Range Test

I was hoping to get away with only having a base station and getting enough coverage for the correction signal with the xbee radios. Our location is very flat and the tallest point is the silo at my parents farm. turns out I better order the XLR version as the LR only has 20mw and the XLR can have 1 Watt. What I probably should have done is just order 3DR radios to make the connection, that would have been cheaper but not as clean to set up.

hopefully this is helpful for some of you,

3 Likes

Maybe optimizing the LR setup would help to enhance the coverage. The silo seems to be a great starting point for an RTK base. However, I would use a high-gain antenna for the base. Reducing the cable length between Xbee radio and antenna may also help. (coax attenuation can greatly reduce your coverage)

For my base station in Europe I am using this antenna I have been using this setup for several years now in an environment with more trees, without issues.

Thanks for the input.
I did use a good quality coax ( 15 ft Low-Loss Coaxial Extension Cable (50 Ohm) SMA Male to SMA Female Connector, GEMEK Pure Copper Coax Cables -) hoping that would help the loss.
The idea was to get make it easier to get the antenna higher, and make it easier to Waterproof. I might have to rethink that.

With your setup can you get good signal 2-4 km away through bush? I would be surprised with only 20mw signal.

European regulations don’t allow higher transmit power. (XLR is not available for Europe) In a challenging environment it means everything has to be optimized. Your cable is nice, but shorter is always better, and being on top of a silo, more height will not add much.

The rover antenna should also be on a high point, testing inside a car may not be ideal. ((fresnel zone)

Normally I work within a 2 km distance from my base, but I don’t have a silo. My base is mounted on the roof of my house and surrounded by trees.

1 Like

image
I’m using this antenna on my base and rover. It is 9dbi. In US I use 900mhz RFD900X radios. Would I gain anything by switching to an antenna like you are using. I think I am having interference problems. When I was using RFD900+ with the shorter 6dbi antenna, it seemed to be fine, however now I’m loosing RTK at about half the distance from the base.

9 dBi seems an optimistic claim for this antenna. Would it be this (eBay) one?
That would explain the performance…

Looks the same, and mine is rfd, so the 6dbi I traded it out for was a mistake.
Thanks

RFD900X Plus 915 Mh Has anyone used this antenna?

I have a set of them. Don’t know why, but I couldn’t get the range out of them. I switched back to rfd900 +, they work very well. The x series kept dropping rtk, plus never does. I always thought it was interference but plus are on same range.

Hello, I have two of these cards. and there are two RFDs. I want to set up my own rtk system but I don’t know what I need and how to do it. Is there a schematic I can follow? can you help me?

https://www.google.com/search?q=rfd900x&sxsrf=APq-WBsf_C4yRjuqzvg_QzgDAwncSW2-Uw:1649493967700&source=lnms&tbm=shop&sa=X&sqi=2&ved=2ahUKEwit3YPwy4b3AhUOJLkGHfRRCgEQ_AUoAXoECAEQAw&biw=1536&bih=722&dpr=1.25

Unfortunately there is not any instructions that I know of.
It is very simple though. Your rfd900 will work as they are. You should really read the setup instructions at the least. They are factory set to .5 watt, which will work pretty far, depending on terrain and trees. You need the rx pin of the radio at the base going to the TX pin on the f9p in the upper left corner of the module. The TX pin of the other radio going to the rx2 of the xbee header of the rover. You will need a 5v 2amp minimum power supply to power the base. They pull some power. If the power is low the red light on the radio will flicker.
Set uart1 on the base to ouput rtcm3 and uart2 on the rover to receive rtcm3. Make sure you have the msm4 messages enabled in the base. Ardusimple has a base station configuration you can download for that. Baud is factory set to 57k in the radios.
The baud in the base and rover must be the same at the uart connected to the radio. If the radio is set at 57k baud, then uart1 of the base, and uart2 if the rover must be 57k.
I always set my radios to low latency and 33 Max Window
The base radio need TX power high. 30 is 1 watt. The rover can be set low. I set them to 10 or 15. All other settings have to be the same in both radios. Download rfd900 program in tools on their web page. If both radios are powered you can program both of them from one radio. The one connected at your USB can send settings to the other one. You will see when you try the program

2 Likes

thank you for answer, ı will do as you say

hi again I followed the instructions but still the rtk led is not active


If I open the data coming from the rfd in the rover part, instead of the gps, directly in the u center program, (ı mean gpsbase> rfd }}} {{{{ rfd>ttl convert> ucenter). I can see the rtcm3 messages sent by the base, but when I connect it to the 2nd port of the gps on the rover, the rtk led does not respond.

I hope I was able to explain what I did and my problem.

If you can see the incoming RTCM, then you need to check the rover. are you plugged in to the RX2 port, and is the Baud rate at uart2 the same as the radio ? Do you have uart 2 in set to RTCM3 ?
Start your base a few minutes prior to testing, then you should get fix right away.

this is port2 my rover

and my RFD

I set all speeds to 38400

and when I receive the data sent by the base gps to the computer via telemetry

Lots of things need addressing.
1st turn off outgoing RTCM3 messages on the rover.
2nd choose either MSM4 or MSM7 messages at the base, not both
3rd if your not in China, turn off the 1124 and 1127 BeiDou messages
4th in the picture the labels on the xbee header are backwards. connect to the tx from the radio to the tx pin of the xbee header, which is the second from the end of the module.

I followed the instructions but still no results.
Rover port 2 : image
Base port1 output:



Everything looks good there.
Where so have your radio connected to your base ? Make sure it is uart 1. If you use uart 2 on the xbee port to send rtcm, make sure you have the base f9p set to output on uart 2.
Attached is a picture of my base. All settings are the same, except I run tx power at 30. tx on the rover at 10.
Don’t forget to copy required to remote :grinning_face_with_smiling_eyes: