AOG with VR bluetooth controller

In search for autosteer engagement method I was originally going to use foot switch then I found VR controller. With @Wazaap post as inspiration.

VR controller.

AntiMicroX for key mapping.

And it works I like DIY but ESP32 cost more then controller let alone work that needs to be done to make it if you don’t have special needs from controller off the shelf ones like this have 6 buttons and 1 stick fits in hand looks good, battery powered fully portable. This should work with any controller that works on Windows.

It would be useful to have more shortcuts and hotkeys in AOG for many tasks, then we map controller to keyboard. And easier way to change key for existing functions, new functions doesn’t have to have keys assigned by default only people that needs them will enable them and choose a key in settings (like video games). So source code doesn’t have to be changed every update and changing source code maybe too advanced for some AOG users.

2 Likes

I have used the same idea successfully in OGX each button can be mapped to a set number of functions

2 Likes

That’s the idea I can’t connect controller to OGX I changed all settings to Open GPS data and try pressing all buttons no response controller is connected to tablet. Is there some connection step for OGX?

When it is mapped to keyboard shortcuts like B N M it works.

I might not have commit the updates to GitHub yet. I’ll have to check tonight. As well that remote may have a different key mapped to it. The remote pictures uses (D0,D1,D2,D3,D4 up down left right on keyboard)

Pg up and down also controls altitude in SIM.

note: above are not the num pad numbers but the ones along the top.

An easy way to see what your controllers keys are mapped to is to open up notepad click to start the cursor and then just go through all the buttons and see what appears on screen. I also had to pair the remote I have in a certain way (for pc as opposed to for a phone) so maybe that might be another thing to look at if nothing appears on the screen.

Without remote just keyboard default settings for test:

D0 : open field
D1: survey start/stop
D2: makes red box green next to survey :joy:
D3: reset blade offset to 0
left: increase blade offset +
right: decrease blade offset -
up: circle options on right
down: nothing
pg UP: increase altitude
pg DOWN: decrease altitude

all remote settings set to decrease blade offset (pressing keys on keyboard):

D0 : open field
D1: nothing
D2: nothing
D3: reset blade offset to 0
left: increase blade offset +
right: decrease blade offset -
up: circle options on right
down: nothing
pg UP: button missing on tablet keyboard
pg DOWN: button missing on tablet keyboard

It seams that remote settings don’t work.

Test remote:

Tested in notepad no response. Only volume up and down worked. In some modes, the C mode where all buttons are available doesn’t have volume control.

vrsettingsmodes

Possible modes

Back to AntiMicroX to bind keys.
In AntiMicroX it reads all inputs from controller and I bind keys as:
A: D0
B:D1
C:D2
D:D3
stick up: UP
stick down : DOWN
stick left: pg UP
stick right: pg DOWN
2 buttons at back LEFT and RIGHT

All remote settings set to decrease blade offset (pressing keys on remote):

A : open field
B: nothing
C: nothing
D: reset blade offset to 0
stick left: decrease altitude
stick right: increase altitude
stick up: circle options on right
stick down: nothing
buttons at back increase and decrease blade offset

Same result as with keyboard.

With these cheap remotes program for binding them to keyboard must be used. Many remotes many bindings possible but OGX system is good. If many are interested in remotes recently many discussion are started for them if a system was implemented in AOG like this many more will use them right now there’s not a lot of shortcuts and process to add yours is complex.

But is this bug in OGX all settings changed none work as intended some stop functioning some retain their old function?

Yeah that is for sure the pre bugged version haha that sounds exactly like would happen before I got it all sorted out . I’ll commit all the updates to my GitHub tonight and get you to try it again.

Try downloading and testing now, I have added the commits from the past few week. Should work for you now.

1 Like

Well I looked at your GitHub I used installer to install OGX which says that it was 3 days ago so same version as before. I see that some things are 13h~ ago.

OpenGradeX/ Installer /

Probably dumb question how should update be done?

My bad I didn’t update the installer. You can just go to the application folder and run the OpenGrade.exe for now.

For future reference though I do have to uninstall old versions of OGX before if install updates as in the past some changes seem to come through where as others don’t. I probably don’t have something configured correctly for updates but this is a workaround for now.

I deleted install folder and documents folder, reinstalled and copy from GitHub Application/OpenGradeX.exe to install folder and replaced original.

Default settings remote works.

All remote settings set to decrease blade offset (pressing keys on remote):

All decrease blade offset

Remote and remote settings now work :slight_smile:

1 Like

Glad it works for you, the options I have listed are just ones that I though may come in handy for me but new ones can be added quite easily as well. As well with the remote I have I stumbled across the functionality to press Start+Btn which will then give you another 4 functions(D5,D6,D7,D9). With these buttons you can hide things you don’t want to accidentally push using this method as you have to push down 2 btns simultaneously. The model you have shown may have a similar option.

I have not added the extra functions to the code yet obviously but it’s all there waiting to go.

I dont have a use for OGX just wanted to try remote
People that use OGX maybe have ideas for additional settings.

I dont have that but it can read 2 buttons at a time up to 5 simultaneously (back button, diagonal stick and A D )
Maybe some function can require 2 pressed buttons.

Testing remote.

3 Likes

Can you send me a copy of the Bluetooth protocol for this remote control?

I dont understand what protocol i just connected it to tablet, just needs key mapping software to get remote keys to press AOG shortcuts keys.