Ardusimple F9P no RTK Fix

I just bought the Ardusimple F9P and have updated the firmware to 1.13 and applied Andreas’ configuration. Seems like everything went well. First of all I have a maybe simple questions: The baudrate has to be set as configured via u-center, so the nmea hz? Ive set them to 115200 and 8Hz, seems to work.
My real problem is that i cant get a RTK fix. AgOpenGPS and u-center both connect to a caster via rtk2go, which is around 40km away from me. Both programs show me mostly float, sometimes DGPS. I have the antenna laying on the roof, with the cable through the window. There are some trees around the house, but the view to the sky is clear (despite some clouds). I also tried running around on our farm, at least where I have internet connection, but nothing changes. Buildings were like 10m away from me on all sides, so I think that shouldnt be a problem…
Hope someone can help me!

Edit: Maybe interesting too: the NO RTK LED blinks, the GPS FIX LED blinks too, but is just a very short time bright. AgOpenGPS shows me 12 sats

Update:Today I went outside on our field near the house, standing completely free with no trees our buildings around me. I started AgOpenGPS, satellites were found, Ntrip connected via mobile Internet, but again Im just getting float, no RTK fix. AgOpenGPS tells me No GPS on the map, and the accuracy is really bad. I walked along a straight line couple of times and found out that the signal drifts significantly, around 30cm in just 2 our 3 minutes. Something goes wrong here, I would expect it to be more accurate even with a base further away.
Update 2: Checked the signal strengh, I have got at least 10 sats with 40dBm or less, even with the antenna on the roof. I read in the ublox forum that this should be really good. I also tested some other bases, around 100km away, same result

Have you uploaded a config file used by the other members of this forum?
For instance try look at this thread:

I used this conifg:

I also tried the older firmware (1.12) with config mentioned here: Ublox F9P - Config for rover, also config directly from ardusimple, no effect at all

I think you should try to take your GPS set up in your car, and drive closer to the base. 40 km is a long way from base 25 km and below is better.

Drove closer and got no change. I placed the antenna on the roof and parked my car on a free field, still just float. I think I will contact ardusimple, maybe they can help me.

Try to re initialize the F9P as default, and connect a ntrip feed in u-center. With the default factory Config it should go to RTK fix with a good ntrip incoming rtcm data

Did that too, but I never got RTK fix at any point. RTK fix does not always mean that I have full accuracy, right? It just means that the simpleRTK2B is capable of using the incoming rtcm data stream correctly. I understand that Im relatively far away from a base, but I shouldnt get drift and pass to pass accuracy should still be good, though maybe the absolute position is not perfect.

RTK Fix is about 2 cm absolute accuracy relative to the base. RTK float is closer to .5 meters. Your pass to pass accuracy should be decent with RTK float, but there’s no reason you shouldn’t be able to get an RTK fix. Are you sure the base station is giving you the right kind of messages?

Finally a solution: After a day of communication with Ardusimple they told me that the base, which I tried to access via, does not send the right rtcm data. I thought that just the protocol is important, and the base sends rtcm 3.3, that would be good. But the stream is partially not understandeable for the simpleRTK2B, so in fact i didnt have RTK at all. I now use a caster around 250km away from me, got RTK fix a couple of times (of course not stable with a base that far away) and a good repeatability. I’ll have to wait until I can get free access to casters provided by my government near to me or build my own base, but I try to avoid that.
Thank you all for your help, I think the problem is solved

Which mountpoint did you use?

It seems like the mountpoint went down yesterday, Im not able to find it in the caster table any more. Its been called something like “Ahrensboek”, I dont remember the exact name