Improved konfiguration files for f9p with firmware 1.13

Here are 2 config files for f9p with my config worked out with ardusimple team.

config for base station with msm4 messages at 1 hertz - usb output (3,8 KB)

config for rover (agopengps version) (3,8 KB)

10 Hertz
output to USB and GGA to uart2

gga+vtg at 10 hertz

Firmware download at ublox

[U-Center Software](u-center | u-blox


To me sbas seems to be an upgrade from previous version , so why sbas disabled ? ?

we use this module with rtcm corrections.

sbas do not work good.

the jump from rtk fix to dgps ist most of the time 1 meter an more.


Is that the sbas on the fp9 that doesn’t work good or sbas in general?

Novotel and others did spend many time to improve sbas / dgps with their receivers. They say about 20 cm pass to pass.

But you pay 2000 and more for that.

With F9p you have a perfect l2 rtk receiver for 1/20 of money of others…

If you like to use sbas only buy a cheap m8t receiver…

Hello! Thank you so much for sharing! I successfully installed and tested it worked well during the test!

Isn’t it more a question of whether sbas could improve accuracy if/when rtk correction fails?

Would base configuration work with ardusimple wifi ntrip master, or are there some settings to change, as it doesn’t use usb? Been a few months since I last used U centre!

I use xbee Bluetooth to make connection from ardusimple to tablet.

I can’t find why but using your configuration file UART2 refresh rate looks like set to 1 Hz not 10 Hz

If I connect ardusimple using USB cable I get 10 Hz

yes. the config is used to send gga to xbee module that sends back to caster every second.

you need to go to ubx-cfg-msg and chage rate from 10 to 1.
and you might also need enable other messages for you

1 Like

Tnx! Works great!

I have build up my base now and I used the config from here. But I wasn´t happy. My rover only showed 6-9 sats and fix was very unstable. I changed the rtcm messages from MSM4 to MSM7 and I get 13-15 sats.

are you sure using a L1 / L2 Antenna - and antenna is ok.

normally you should receive up to 30 sats.


Andreas, you mean the antenna for the rover or base?

At the moment I am testing in office: the base is a F9p at RPi and for the rover I use a m8t with rtknavi. So the rover is only L1. But I tried the Sapos-RTK as well and that gave me 13-17 sats and a stable fix. The fix of my own base is not so stable. Maybe the big, old oak 30 meters away is a problem. Until now I am not so happy with the reliability of the rtk fix. But MSM7 improved the signal a lot.

How can I find out if the antenna or its cable is sligthly broken?
Strangly I get a fix after a while, but then I loose it 10 minutes later and it doesn´t come back.

At the moment both base and rover antennas are very close to each other and rover doesn´t move.

I am not sure if I can rely my base now.

“At the moment I am testing in office”
Office tests with RTK are usually not successful. GNSS antennas must have an unobstructed view of the sky in all directions.

The antennas are on the roof of my house. So this should be no problem. The trees around are a bit annoying, but I have no better place.
Is there any reason why I should use msm4 instead of msm7?

Again , what kind of antenna you are using at base station ?

Manufactor l1 Or l2

Oh ok, the base has the standard ANN-MB. i bought it from you with the ardusimple f9p.
Would it improve the base quality if I use a better antenna?

On the ardusimple site it says: " * Performance can be improved by using MSM7 messages"

So it is no problem when I keep using msm7?

Check following:

Base firmware 1.13
Using my base config file
(Do not forget to save config)

Open Ucenter again and enable ubx messages - check visible sats
(Should be 25-30)

I am running about 40 base stations with that config and Ann-mb

Msm7 do not bring any advantage with our products .

M8t is not a good Rover for rtk anymore.
Sorry but it into a museum.

You can also contact me via WhatsApp Telegram and we can der what’s going on faster…