Beta 4.2.01 on Github Branch v4201

Trying a new strategy - a Beta version. It seems impossible to find all the bugs by just thinking they are all found - there is always more. So a Beta version has been posted, the program, source, Arduino Code. Give it a try, find any errors, problems, strangeness and please post here. Not on Telegram!!!

Special note: Does not work with the DOGS2 Sensor yet. Still figuring that one out.

Available from here:

French, English, Default US keyboards. Turn on in settings
Checksums to Arduino modules.
MMA filtering, turned down a bit to ensure it is stable for now.
Twice the WAS resolution as before - twice as hard to set zero.
The “Dot”
A million fixes from v4.1
Single P setting for gain, Drive button at bottom of Steer settings for easy access.
The buttons for Drive in steer settings are repeating buttons.
Hit zero button to zero the Drive direction, hit zero button again to go 5 degrees right. Nice to check response.

Careful when entering filenames field names etc, only use “normal” characters. Underscores ok.

And to all who are willing to test this version - Thank You!!!


another bug.

if smooth a a-b curve it is not saved…

you can check it by creating 2 a-b curve. and smooth them

if you switch between them it is lost

Hi Brian, more great work here! Many Thanks.
3 bugs I found:

  1. Max steering angle - the bar changes but the program still uses 40 degrees as max

  2. Red/Green circle - no values inside - was the PWM value in Video.

  3. click on change in data sources - no checksum ? needed?


  1. Just tried setting to 68 and AOG generated a turn of 68 required, tried 18 degrees and maxed at 18.

  2. Yes, removed. It is on the Steer settings now at the bottom. Not really needed to be seen all the time - was kind of ugly was the feeling

  3. Data sources only reads info from the arduino, but doesn’t change anything in the arduino. Therefore the checksum wouldn’t change anyway.

Did i understand the questions ok?

Thanks for the quick reply
1 ) will test further on desktop with Win 10; are now loading on Win 7 laptop to test on mower
2) okay, understand
3) okay re data sources; was thinking in terms of verifying the config changed but yes, it’s not writing.
Yes, you got them.

Latest update on Github.

INO code supports DOGS2.
Adjustable IMU/GPS fusion amount.

Brian there is a bug in section widths. I was able to duplicate this one in link below. Seems like something doesnt add up right with the section width and number of sections. when I close program and open it it gives those errors and section width number has changed.

I did try a bunch of combinations, they seemed to save and load fine. If you delete the tool file and start from scratch, does it then work? I posted on the other thread but almost everyone uses metric so haven’t been testing imperial very much at all.

And i tried it a few more times and it did crash: I can try to fix it.

Found the bug. It always scares me when i have to look at that part of the code - its enormous.

Uploaded to github. Be sure to download the updated ino’s as well. It is a Beta!!!

The default width was being converted to imperial, but not on the way back, so it got smaller by 2.54 times every time the tool settings was opened. Do it a few times, and it gets below the min max limits of the numeric spinner. Crash boom.


Thanks Brian. You must be able to handle a lot of pressure. Especially this time of year. And to think we are using AOG for free. Makes me feel bad at times. THANKS

1 Like

Wow…thanks for digging into it and finding the needle in a haystack. I was really not looking forward to getting used to having a 457 cm tool width! Appreciate all your time and effort in this.

Awesome work! Was this bug in the v4.1 as well? I was having crashes today while messing with tool as well.

Probably yes it was. That was a tricky bug, you had to go to the settings page a few times, and not change the default size.

The thanks is to you guys for running into it. You can imagine, as a programmer it would take years to do the right combination of steps on every form setting the right setting to run into a bug.

Exactly right. It was on my planter and I kept going into the settings to try to get the overlap correct. Which brings me to another odd problem is that I keep getting a row spacing of 27” (suppose to be 30”) and even when I put a -3 in the overlap section it doesn’t want to move over. It stays consistent at 27". I was successful by changing the implement width but not sure why the overlap wouldn’t correct it.

A couple questions

I see a variable HydLiftLookAhead, which looks like a time in seconds that then gets multiplied by speed and converted to distance / pixels. I also see where it’s stored in the Vehicle file. I was hoping this would allow changing the lift point as your coming up to a raise or lower point on the headlands. In playing with the variable, I can’t see any change in behavior. Is this implemented and what is the purpose?

Also, when going into a headland and there’s already and existing headland, if you enter a new offset value, it adjusts from the existing headland, not the field boundary. A way to show this is go into the headland and put a value in the top box, just keep hitting the green arrow and each time, the headland shrinks more. I was expecting the behavior to be that the value entered is absolute vs the field boundary vs. relative to the last headland.

That allows you to add a little bit to an existing headland width. Its a tough form because there are so many actions to perform. Often just easier to reset and start again

There is no adjustment for lift point when leaving the headland, only look ahead before entering the work area/leaving the headland area. The only time you can trigger a lift is when you completely leave the work area and are fully in the headland

Thanks for the info on the headlands. edit: am I reading the code correctly that the headlands defaults to 3 passes?

For lifting, I will end up using the section control that allows you to adjust timing for on and off to trigger my raise / lower. It gives the adjustments needed. I don’t have row shut-offs, so my planter is only 1 section.

In V4.2.02, are the metrics on the bottom of the screen and the second left-hand menu intentionally excluded. If there a way to turn them back on, or are they buggy?

I have not been able to migrate to 4.1.12 or 4.2.01 successfully. I’m running a Cytron controllng an AgLeader Ontrac 2 motor. Version 3+ is working okay. Current PCB purchased. A2D Converter is Single. Inclinometer is MMA4852 (1D). MMA axis is X. Steer enable switch is button. Using 10 hz. RTK. WAS works. Steer switch button works - changes between 5 and 7. Using Imperial units. I’m changing the ino when I switch back and forth. Uploading 4.2.01 and watching the check digits, everything seems to be in sync. When I use the Drive button in either 4.1.12 or 4.2.01 it wants to turn the wheels slowly one direction (left) and turn until I shut it off. I need to plant for 2-3 days. Then I will experiment more.

I’ve uploaded 4.2.02 Maybe that will be better? V4.2 is the ever changing beta - but the latest is quite stable

For those that are bench testing new version. You need to have WAS installed and not at end of stroke or motor will NOT work. Nice safety feature but caused me an hour of frustration. :slightly_smiling_face:

1 Like