Beta 4.2.01 on Github Branch v4201

Hey Brian. Are you successfully using a brick in V4.2? I can’t seem to get it to communicate. I have the uid set and heading source set for the brick but The IMU reading sits dead at 0 degrees. The brick works great in brick viewer not sure what’s going on

I did a testdrive today with a brick on
All works fine without problems. Maybe remove old files, don’t load vehicles or envoirment and try again

It’s kind of like a flexi coil sensor - if its not there or shorted out, its a problem.

Also, there is a new Beta version 4.2.02. Seems to be working pretty well, except for antenna offset. Still need to come up with a resolve for larger distance offsets.

I haven’t found 4.2.02. Is it uploaded to github?


v4.2.02 is in the 4.1 branch. Still in beta but will release soon.

I’ve just tested it, didn’t find a single bug :grinning:

Still haven’t done a thing with my bumby oem was.

I seem to have found a way to totally lock up the program. Selected the wrong port for autosteer (Serial/USB). the port I picked was a Bluetooth to USB adapter on the computer. It locked the screen. After waiting a couple min and nothing happened, I killed the program through task manager. When I restart, it’s still unresponsive, it shows the main screen, but won’t respond to any inputs. I’ve gone as far as deleting the directory and unzipping again, plus rebooting the computer and it’s still locked. I’m guessing it’s still trying to connect to the same com port. Any thoughts on what to try ot get out of this state or reset the com ports? (This is the latest 4.2.02 downloaded today).

Edit: I was able to get it back by disabling the com port on my computer. T/hen when starting, it gave a ‘com port doesn’t exist’ message and functions again. Not sure what this com port is doing, but wouldn’t think that it should make the program completely unresponsive.

Setting up 4 wheel drive tractor…my GPS antenna is out front on the hood not behind the front axle like the diagram shows… Is there a fix for this, on version 3 I used the standard 2 wheel drive tractor settings.

I guess don’t do that again :slight_smile:

Just use the standard 2wd selection - i just haven’t had time to work on the 4wd. How it works for 2wd hasn’t changed, so it should work the same - i hope.

Was hoping to get my case 500 hd hooked up, but weather and time killed all hopes of that.

I moved the whole setup from the planting tractor to the spraying tractor and the brick magically worked. I changed absolutely nothing other that the loaded vehicle. Strange

I’ve been trying 4.2.02 at home before I go drilling again and am finding steering very hard to tame. 4.1 was nicely progressive and worked well for me. Some issues with curve but far tamer than what I’m trying to set up now. it seems to either run at the low pwm speed or jump to the high one with no progression. Roll is also very lively and rougher fields are throwing the steering about too. Boundary curve following that was so good in my 4.1 is almost unusable it’s so jumpy.

Could setting the low pwm too low cause this?

I’m out of the tractor now but have played with so many settings I can’t remember if I tried raising it. I’m a bit lost as to what was better and what is worse. Others are getting on well so It’s obviously my setting up that is the issue but I found previous versions relatively easy to get near correct.

To partly answer my own question, yes, low PWM set too low on my system wasn’t giving low PWM enough scope to correct some medium errors. AOG then uses MAX PWM to correct the increasing error making things very jumpy.

That’s what I did with version 3 worked very well !

it isn’t one or the other, it’s gradual from low to high as the error goes from 0 to 5 degrees. Oddly lowering the setting for min pwm and puttinh LowPWM at that old level seemed to work for me. You just gotta try different settings

In the field it made my steering slowly try to correct but not in time then correct reasonably violently with corresponding overshoot. I am testing in a medium bumpy field and the new more lively MMA action might not be helping. IMU output is absolutely rock steady. GPS seems more likely to do the magic roundabout thing when stationary with the new version. Not seen that for many months previously.

I have done my first run with 4.2.02 yesterday. So far it works for me. It is great to have a simple change of pwm frequency in that sketch. Now, with the lowest frequency, i have no more annoying sounds from my motor.
But where have the displays of worked area netto/brutto gone? Please, put them back in somewhere. Or cant I find the button for it? I would only need these informatoin of brutto and netto worked area. Another point I dont really understand is the “min High PWM”. Can someone please explain me that option.

1 Like

Alan, I think the same. The mma is much to lively. It is not helpfull to let AOG know every bump in the field. It is enough if it knows, it is a sidehill more or less to the left or to the right, but this steady.