How to export rtk NMEA0183 from teensy to rs232


does anyone have an idea how to export gnss position with rtk correction in NMEA0183 format from board/aog for external section control devices via rs232 port?

Thanks for the ideas.


No, but I also would love to know.

Im trying to use f9p uart2 with rs232 that should work but not sure if Xbee Wi-Fi ntrip works at the same time.
Uart1 to teensy.

1 Like

Do you mean you NMEA output with corrections for roll mixed in? Or do you just want the F9P’s NMEA stream to also go to RS232 to use with another monitor?

If it’s the latter, that’s not too hard. You get a MAX3232 breakout board, and tee the TX wire to the F9P’s TX for uart1. The MAX3232 has very high impedance on the TX line, as does the Teensy, so it’s okay in this instance to share the line between the two devices (the RX on the Teensy). It won’t pull the voltage down enough to cause issues for either device.


C$ 0.87 5% Off | MAX3232 RS232 to TTL Serial Port Converter Module Female DB9 Connector MAX232 Flashing Board For Arduino

Ttl to 232


you can also get them on for pretty cheap.

1 Like

I want the F9P’s NMEA stream to also go to RS232 amatron 3.

I didn’t think it would be so easy.
The diagram is correct?

The configuration will be correct?

Maybe better use uart2 in case of single antenna? And set baudrate 19200 or 115200 and protocol out only NMEA?

1 Like

It will work as shown for both only if they have the same baud rate board and other device.

You would have to use separate uarts for independent baud rates. If you are using dual the second f9p uart may be taken.

The little converters are great, but the tx and rx silkscreen for the pins are not written in stone. So you may have to try both pins separately on the converter to discover the correct one.


Should I also select UART2 in the MSG configuration?

Should I select GGA, GSA, VTG for UART2?

1 Like

It works :slight_smile:
Thanks for your help.


Awesome, great feeling when everything works! for a $1!


Did you use uart2 to send that nmea? I need 19200 baud to amazone gps so teensy uart1 won’t work? Did you change those messages to uart2?

Yes, I use uart2 but at 19200 baudrate and 10Hz there is a problem with amatron, it can’t keep up with processing nmea messages. For amatron it should be 5Hz GPGGA, GPVTG, 1Hz GPGSA, GPZDA.

It works perfect.

1 Like

I dont get it to work, it sends something to amazone gps switch, gga vtg and gsa flashes and it shows numbers but dont find GPS.

I tried with Trimble and it works on that. Messages shows differently on GPS switch.

Any ideas what to try?

Tried to change f9p configurations “rates” to 200ms so then its 5hz? Its on other configcs 100ms
Then tried to change from messages uart2 gga vtg gsa options. What does that number mean its default 1.

Maybe the Switch only accept GPS messages GPGGA and not GNGGA
Search Google for this line (trimble specific): ptnlid gnss message

1 Like

RTCM 3 Message List - SNIP Support (

4094 is trimble

If your configuration rates is set to 200 ms, then a setting of “1” means every 200ms. If it was 2 that would be every 2*200ms, or 2.5 hz. Hope that makes sense.

The cause of your issues very much could be the fact that the F9P transmits GNGGA instead of GPGGA. Unfortunately I’m not sure how to tell the F9P to make it GPGGA. Perhaps the F9P will only emit GPGGA when it’s only using GPS and ignoring all the other satellites.

I suppose one solution is an arduino sketch that reads in the GGA sentence on one serial, converts the talker code to GPGGA and retransmits it out another serial to your RS232.

If I remember right, F9P can be configured to use GP message heading instead of GN, a setting to be changed with u-center.

I know you can configure the f9p to send GP instead of GN because I had to do it for 20/20 seedsense, but I don’t remember exactly where. It shouldn’t be too hard to find.

Edit: Here is a link to an article that describes how to set your talker ID

1 Like