John Deere hitch control / hms button activation

yes this menu


need to load the Ino modified in your autosteer board
reload the AOG value steer & the raise and lower (as you show)
physically add some relay to transform and isolated D2 D5 signal
connect the relay to switch of the tractor in parallèle

after start a field
make bondary, headland , AB line

activate the ABline , the headland, raise lower icone( need to be green) , auto section and accross the headland line
green or orange Arrow will be show action and autosteeer board send to D2D5 the action

if you want check the icon on this video at 2"06

it is so good !!! for me


Some request, so find additional information ( activate subtitle to have explanation)

Hardware so How to do it as example here: my test with John Deere 6010 & 6030P

Software How to upgrade the nano, How to set the nano, How to use it:

Arduino program for V5 : autosteer.ino adapted available here

Can be use with other brand if similar …

Farmer helping Farmer!


Have you tried if this .ino works with the latest AOG v5.5?

not yet

but i will try this week end

@Kaupoi because I m really curious about this new feature of 5.5 , i cannot wait more and i test on simulator/board with the actual modified autosteer.ino

First Brian &co do very good improvement !

second on simulator with board it is working !! so so good!

1 Like

Mine is not working. Testing by driving tractor on yard. Using your ino I downloaded couple months ago. Arrows goes up and down on screen as they should, but nothing happens in steer module. If I tab “invert relays” and send at hydraulic lift config window, relays pull and jd screen shows error. So relays does work and pinout is correct anyway.

What could cause this issue?

Did you modify the latest ino or using the older modified one?

SOLVED: Autosteering must be engaged for lift control to work.

i retest today on simulator and it works with previous link
need to be sure this parts will be updated on nano

and also this one

after i start yesterday to upgrade with new ino deliver with 5.5 support but it is not working today i will continue

1 Like

Realised that autosteering must be turner on for lift control to work. Tested again with autosteering and it really works. So it was just a stupid user error. Sorry for bothering you with this and thank you for this awesome mod.


thanks a lot to your feed back

but i really want to update with last Ino but no good result again

1 Like

small update for new ino files5.7.2 USB and UDP here!