New Version 4.1.1 - Hardware Software, Testing and Hooking up

New version update here :

Install video : Arvel Installs Software and Firmware

Please download the AgOpenGPS and run the installer. Download the (don’t forget to Unblock before unzipping, right click, properties, at the bottom) and install either the usb or udp firmware into autosteer Nano. Be sure your hardware is hooked up as explained below, in the schematic below, and video below.

New version with only a very few changes, but important ones. So many posts about problems and i hope this version along with associated video really helps explain how to hook up, pins to use, how to test and what each part does and for what reason.

Recognizing the individual parts is important. So much time has been spent developing software, it is extremely time consuming. Lately much time has been spent on consistency in naming, in the Application, in the arduino code, and in the hookups. Ease and consistency helps reduce problems. Next is the WIki and documentation, another huge job.

Here is the schematic for the video:

And of course the video:


Awesome, thanks for that. Curious if the module configuration changes that are made are reflected in the support folder? None of my nanos will update through AOG

Did you install the new arduino software?

Just updated the software changing the name Encoder to Turn Sensor. I forgot to update the language file to say the correct words :frowning:

Updated the units in the arduino toolbox first and seems to work now, thanks

1 Like

I have finally hooked up my board to power (no smoke), and downloaded the latest version along with support files as in the video. I keep getting that my steer module not ports are correct just not getting signal back. What could be the issue? I tried last night and I thought is might be due to steer switch was not connected but I connected it today an still same issue. Hope this is just something simple that I am missing.Checked power to board and that is ok, WAS power is good and adjusting when I move it, testing with voltage meter. Light on nano is on. The serial ports and modular configuration screen shots below



you can literally unplug the nano completely from the board and connect it to the usb cable. Turn on the serial monitor, what happens? Set the baud to 38,400.

nano disconnected restarted and now serial monitor shows numbers in the “from auto steer”


Have the power (on/off) wires connected? Should power on with just USB connected, try powering it on before you open AOG. If that doesn’t do it upload the sketch in arduino first then open AOG, they are in the support folder. Had to do that with one of my boards as well


1 Like

plugged nano back on board and it says steer module not connected

reloaded nano from support files same results, steer module not connected. tried all combinations of power on before and after AOG start up still nothing.

When you’re in the tool box, it reads the data correctly from it? If you can see it there and the com port is the same I’m not sure why it won’t show up

this is what I am getting in the serial monitor

Set the baudrate in the right down corner to 38400

set the baud rate to 38400 and with the nano disconnected from board I get the following readings in serial monitor. so at least I am getting that, When I attach to the PCB board I do not see those numbers and AOG still shows steering module not connected.


Something wrong with your pcb? Could you attach some photos of it here?

pcb hookedup2 pcb hookedup1

Can’t see any obvious faults, but where is that red wire from cytron nc connected. You should remove that wire. It’s not needed. Maybe a good idea to take a closer look at the solderings if there is a short circuit somewhere.

Definitely a board problem. So remove the ADS, MMA, the Cytron, Nano. Connect power to the bare board. Make sure you have 5v on the board where it should be. If that is ok, plug in only the nano and connect to arduino serial monitor as you just did. Start adding the ADS, try again.

Methodical troubleshooting - from known working step to determining where the next potential fault may be

Hello What causes the problem of the program constantly disconnecting from the gps and autosteer port? I have already replaced both the usb cable and the hub but it still disconnects from time to time!

Hi Brian, great job on Version 4.1.1 software!
The 2 videos helped in ensuring the software was loaded correctly and setting up the board and confirming correct operation of the I/O. Big step forward!

I’ve also experienced occasional, random issues with the Arduino not wanting to release the old program when attempting to upload a new sketch - I think it may not be just an ag-open issue.
Sometimes pushing the button on the nano board just before uploading but not always.

For future consideration - suggest another series of videos which will reflect the new SW:

  1. the basics of creating a Field, Boundary and Headlands, AB lines and on the next SW release, include a simple field and boundary with all the bells and whistles. This will hopefully provide other users a solid foundation to start, and you may get less questions to answer.
  2. Another video re GPS and current configuration options and how that will work inside AgOpen - big topic

Once again, Thanks for all the great work here!!