Panda configuration-beginner questions

This past year I have been using AOG with my gps over USB (pcbv2 for steer board) and I’ve finally had some time to get a panda board put together with the goal being UDP. I have been using the F9P configuration files from Tony with the 1.13 firmware. The base station configuration file finds and locks coordinates in 4-5 minutes(for a mobile base over LR xbee) and then sends the correction data, but I don’t believe there should be anything on the base that would need changed if someone could confirm that for me?
I used the .ino to try to change the settings on my rover but I am really not confident I have them all correct (u-center doesn’t seem very user friendly to me!) so I was also curious if anyone had a configuration file for PANDA over UDP that would work with my mobile base setup. Or a step by step dummy guide of the settings that need changed would be great!
All that aside, I did manage to get panda data sent into AOG today which was great! But I haven’t finished my board to the point where the teensy/Bno/F9P are powered from a 12v source, so it was also hooked to my computer by usb so I wasn’t certain the data was coming from the right place. Later this week I should have the parts to finish(micro usb, screw terminals, and dc jacks) so I can test it correctly with the UDP being to only connection to the computer. Thanks for any help or advice!

I did some more tinkering and found out the PANDA and IMU data I was getting into AOG earlier were through the usb. I decided to power my panda board through the teensy from a power bank and connect the Ethernet only to the tablet and I couldn’t get any info. It would show a green box around the controller and show an ethernet connection but no IP address would show up in the “module scan” boxes.

Quite a few have forgotten to connect the 6 ethernet pins from teensy to pcb. So do you have them ?
Also check that you have teensy 4.1 with ethernet, and not the 4.1 without.( the 6 holes are on both, but ethernet chip might be missing)

I was afraid that could be a problem…I do have the 6 pins sandwiched between a female socket on the teensy and a female socket on the pcb but I was concerned I may not be getting a good connection there. I’ll try to check that connection later and try again. I do believe I have the correct teensy with ethernet chip

Yes with ethernet :smiley:

1 Like

can u connect teensy too the computer and open Monitor port in Arduino program and make scren something like that

and paste it here

I wanted to say that maybe the problem is with IP address, but I tested it myself and it’s probably not it…
I would try to connect to another computer via UDP, if it works, there may be something on the tablet side or if it doesn’t work, maybe there is something wrong with the PCB.

1 Like

You must sort out what ip you want to use. You use two at the moment. Both 1 and 3.
In your first picture you have typed 3, but have you clicked on set (should send and set teensy to 3 instead of the 1 that we can see it still is at)

1 Like

Another thing to add: I can see you have computer connected to something(a router?) by WIFI. I do that in the office, steer board to office router and WIFI from tablet to same router, that does work when I use the IP number the router uses/deliver. I you have steerboard connected direct to tablet, then probably disable/turn off WIFI
You can also watch FarmerBrianTee videos about UDP and IP config if you click on the Youtube icon at top of this page

1 Like

Thank you both, I will try those things and report back! I had also noticed the different IP addresses when I connected the teensy by usb to read the serial monitor so I tried changing it on the computer to what it was on the teensy and nothing changed. I’m fairly certain I hit “set” so I am wondering if that points again towards a connection issue somewhere on the ethernet?

Some progress, I think! I have determined I am getting panda over ethernet now, I switched everything over to a different pcb to test (but I think the original was fine). I noticed I had been getting a green box next to the gps in the module scan, even though an IP address wasn’t showing up. (Maybe it isn’t supposed to?) I decided to take everything outside to see if I was getting GPS or IMU data and they both showed up on the main screen. (I’m guessing the IMU in the bottom right of the screen comes from the panda sentence and not directly from the IMU?)

For some reason I still don’t get the “alive” green box status by the IMU below.

I also just updated to the most recent release before I started working on this- v 5.8.1 if that makes any difference

did you solved your problem, if not you can look for tips in this topic, I think someone had a similar problem to yours, with establishing a connection via UDP ( site 834 user Serhii )

can u tell which version of the board do you have and which version of the software have you loaded for Teensy?

Thanks for your help @Lukasz ! I think I have it fixed but I’m not certain. I was able to get panda over udp but I wasn’t sure why the IP address didn’t show up in the “module scan” or why the “alive” (green box) status wouldn’t show up on the IMU even though it would show the roll in the bottom right of the screen. (I sent a couple pictures showing this in my last post) I was curious if there was something I missed. I am using the old pcbv2 over udp( I used it all last year with no trouble) but the problems started when I just recently built a panda board with hopes of upgrading that part to Udp as well. I uploaded the auto steer v5_5 on the teensy.

Here is my board, I’m not sure if there were different versions of the panda board released.

I remember that I missed the green IMU as well. Haven’t been out in tractor to check if it is so. Perhaps it was solved with a teensy software update.
Or it only happens every second connection, so turn off power and repower?
Maybe check this thread

I tested Teensy on two other software
these are the results, don’t ask me why this is happening, I can’t answer it :]


I will add that I have made a simple diagram

That’s interesting, as long as it working and I now know it isn’t something I did wrong I’m happy! Thanks again @Larsvest and @Lukasz

1 Like