RTKBase: a GUI for your own Gnss Base Station

I mean an additional tab “users” in which you can see who is connected to the base

Is it possible to run RTKBase without it setting up the F9P for me? I’d like to try it but I already have my F9P set up the way I need it for my base station (with specified coordinates) currently, but I’d like to play with the RTKBase software.

RTKBase will only automatically set up the F9P if the F9P is connected using USB the very first time you boot RTKBase. On subsequent boots it will not automatically set anything up.

Just don’t have your F9P plugged in the first time you boot and it won’t change your F9P. If you do this and later decide that you want RTKBase to configure your F9P, just follow steps 7 and 8 of the other installation on the main GitHub page.

I haven’t played with U center too much but I assume that you can pull and save configs? Best to make a backup before starting?

1 Like

Rtkbase doesn’t use the F9P rctm messages, it calculate it using rtklib from ubx messages.

You must note your coordinates and put it back through the setup page after installation.

Ok, I understand.
When you use a Ntrip caster like rtk2go, there is no “user” connected.
It could be useful only when the local caster is enabled.
Is this relevant ? I don’t know, I should think about it.

This is only a proposal. It’s not important, but it would be nice to have such an opportunity when we share the base with friends.

I don’t use rt2go I have an external ip I can forward port 80 and especially now I can easily change it great option

Yes, it’s possible. Even better, you can use your real Gnss base as input to the other RTKBase installation. Instructions:

sudo systemctl stop str2str_tcp
sudo systemctl stop rtkbase_web

edit settings.conf (nano ~/rtkbase/settings.conf)
You must enter a dummy value for com_port like ttyACM0
Edit receiver_format (ubx for F9P)
Edit ext_tcp_source with the Ip address or domain name of your real base, and ext_tcp_port with the port used by the main service (usually 5015)

edit the str2str_tcp service (sudo nano /etc/systemd/system/str2str_tcp.service) and replace in_serial with in_ext_tcp on the ExecStart line
then update and restart the services:
sudo systemctl daemon-reload
sudo systemctl restart str2str_tcp
sudo systemctl restart rtkbase_web

Not anymore :slight_smile:

It’s a new feature of this future release: You can detect and configure the F9P after the RTKBase installation, from the web interface

1 Like

Can you explain why you would prefer the rover IP instead of the user name from login credentials? My rovers do not have a fixed IP address, most often not even public. Difficult to figure out who is who from their IPV4 address.

Something like SNIP has would be nice (but not essential) where each active user is shown on the map, like the base position is now shown on RTKBase.

There’s only one username/password for local caster tho - seems a bit pointless showing “connected users”? Showing the rovers on the map could be useful but only if they’re returning their position to the caster (not mandatory, but AOG will I believe).

1 Like

Hy, I assembled the base station, signal strength is adequate or what is the minimum ?
F9P modul conected 10meters RG58CU cable in GNSS Beitian antenna.
RG58 cable fits the purpose ?
Sometimes there are 4-5 yellows.
Best regards !
My signal

My own base.

Satellite which are low on horizon, will always have a lower signal level.

1 Like

Thank you Stefal in info.
I ask because the Orange Pi has stopped a few times, i thought it was because of the gps signal. But then that’s not the problem.
Orange Pi unplug it and plug it back in, then you can access the web interface as ssh again.
I went out with the tractor today and I see that there is no rtk fix.I came home and restarted it. I’m looking for the problem, why it stops by itself. the next step change microSD card…
Best regards !

I had some freeze with my old Orange Pi Zero with 256MB of Ram. I didn’t have any problem since I switched to a 512MB model, 3 years ago.

I think the microsd problems. My Orange Pi 3 models
I’ll let you know if I fix the problem
Best regards!

Also, check it isn’t overheating …

~65-70 celsius


1 Like

Beta6 is available:

wget https://rtkbase.eu/rtkbase_release/rtkbase_2.4b6.sh -O rtkbase_2.4b6.sh
chmod +x rtkbase_2.4b6.sh
sudo ./rtkbase_2.4b6.sh --all bundled

edit: new file uploaded @ 2023/02/04 12H40 UTC


RTKbase 2.4b6 can not yet be upgraded from 2.3.4 ?