RTKBase: a GUI for your own Gnss Base Station

I had a double NAT setup and I was able to add a port forwarding rule to the ISP’s router through their webpage. I had to create a port forwarding rule in their router to forward the port to my router, and then create a port forwarding rule in my router to forward the port to the Pi.

My new ISP uses CGNAT so no amount of port forwarding would work. Tailscale works beautifully for this.

There are three free NTRIP casters that I know of, and RTKBase can send to two simultaneously. So don’t worry too much about outages then:

Rtk2Go
Centipede
RTKdata

And RTKdata can also aggregate mount points from RTK2Go and Centipede, making it easier to switch mount points when there is an outage.

Do You know if I can run this “tailscale” software on trimble gfx-750 device?

You cannot. It runs on Linux, Windows, MacOS, Android, and iOS only. With AOG, you would run tailscale on the tablet.

Theoretically you could mate a Raspberry Pi-like device with a USB cell modem and a USB to RS232 adapter and build a custom tailscale ntrip client device that can connect to your local ntrip over VPN and pass the rtcm to serial port to the gfx-750.

With commercial GPS receivers, normally you would use tailscale on a Android phone with a bluetooth serial adapter on the GPS receiver, and the Lefebre NTRIP client. Downside is you have to have your phone connected all the time to get RTK. I ran my Trimble 372 that way for a year or two before I had my permanent base station transmitter installed and then switched everything to radio.

GFX-750 is Android based tablet, so… maybe there is an android app. I need to check it out.

Everything Torriem said.

A GFX750 can’t connect to a wifi hotspot? Then you could just run tailscale on your android/iPhone and make a hotspot.

GFX750 connects to wifi hotspot, but I use 4G HUAWEI wifi router, so I can not run any app on it. This router is placed in the tractor forever. So would be better to run this vpn app on the GFX

1 Like

RTKBase v2.5.0 is available!

It’s now compatible with Debian Bookworm.

To update your base, just press the “Check update” button, and wait for a few minutes (5 to 30mn).

The Orange Pi Zero image will be available in a few days. The Rapsberry Pi one will follow later.

Changelog

[2.5.0] - 2024-01-30

Added

  • udev rules to create ttyGNSS port for usb connected F9P.
  • Added UART connected F9P detection and configuration.
  • Some scripts for using a base with a 4G Simcom A76XX modem. (Beta).
  • Rules to manage rtkbase services without sudo (Bookworm or newer).
  • Trying to detect the wrong cpu temp on Orange Pi Zero. #224
  • Buttons and collapsing informations on the diagnostic page.

Changed

  • RTKLib upgraded to release b34i from rtklibexplorer.
  • RTKBase now use a virtual environnement for the python environnement
  • install.sh → --detect-usb-gnss renamed to --detect-gnss
  • Rinex conversion → limit to 2 frequencies removed in “full” presets
  • Rinex conversion → receiver option (-TADJ=1 for ubx) is sourced from settings.conf
  • Logs → default time overlap changed from 30s to 0s

Fixed

  • More tests before copying RTKLib binaries. #313
  • Skip unknown section or key when restoring settings. #336
  • Fix space detection in various forms inputs.
  • Fix broken form input validation patterns. #353
  • Fix some issues with Orange Pi Zero images. #361

Security

  • Update of various python modules.
  • Apply some restrictions on RTKBase services. #341
7 Likes

finally started my rtk base,
there is a question - do I need to get baidu data?
I’m located in Poland so I hope GPS, Gelileo and Glonass is enough.
Does it have any impact on performance?
Just now I have a lot of data provided to rtk2go
GPS+GLO+GAL+BDS+SBS
Here is the link to my station rtk2go: http://rtk2go.com:2101/SNIP::MOUNTPT?baseName=GRYacentY
And the screen from the rtkbase

hy, since it’s winter, I have time to play :grinning:
I thought of an orange pi LTS because it has an integrated ssd memory, so it is faster than the micro sd card because it is not needed.
It has Debian on it, it works pretty well so far, sometimes it stops and freezes, but then I unplug it and it’s good again.
anyone else using orange pi LTS? or am I the only one having this problem?
I’m trying version 2.5.O now

best regards!

How to install tailscale on the same raspberry pi the rtk base is operating?

tried to connect my basestation to trimble gfx-750.
No luck.
Mountpoint is not visible. this is the error on the trimble screen.
I provide basestation to internet by rtk2go. here is my station: http://rtk2go.com:2101/SNIP::MOUNTPT?baseName=GRYacentY

I’ve read that I should provide 1007 signal. How to get it on RTKBase?

Under Rtcm messages in NTRP A service settings maybe?

great, thanks, will see if Trimble would start receiving correction

1 Like

I don’t think adding RTCM 1007 makes the mountpoint visible if isn’t currently. Perhaps better to discuss that further on your other thread.