RTKBase: a GUI for your own Gnss Base Station

I’m using raspian on a pi but switched now to Emlid.

I will release a new flashable image for Orange Pi Zero with Armbian bookworm and RTKBase 2.6 soon. Hopefully next week.

3 Likes

@Stefal @gameo Hi, after messing around with the terminal I successfully updated bullseye to bookworm. Just followed the instructing and after three failed attempts I figured out that after updating you must uninstall rtkbase and delete all of its files with the command (rm -rf) and install rtkbase again it works. I will post if this solves the problem we’re having with the stuck transmission

1 Like

Monday I had a similar issue, I lost my NTRIP connection to rtk2go while spraying - the site was still up but it said my mount point was down. But when I checked my alt (Emlid) that was running just fine, so the issue must have been on rtk2go’s end.

However - about an hour after that, Emlid lost its connection. But I was able to just pop right back over to rtk2go. So I have no idea whats going on where my base station is remaining online, but the NTRIP casters are having similar issues but at separate times. Weird.

Lesson is always have a backup caster just in case.

2 Likes

Update, today everything was working fine and then it just stopped, nothing working, can’t even ssh to it. This never happed with bullseye.

I need to mention that the base is working on poe but that never caused problems so far

Update here as well, RTK2Go went down again yesterday and again this morning. No issues with Emlid. If you don’t already, I highly recommend you set up a fallback NTRIP caster.

On that note - does anyone know of a good self-hosted NTRIP caster that runs on Linux/Docker/Synology NAS? I tried using Tailscale with the RTKBase service but can’t get a good connection on Ag Leader, I think the VPN slows things down too much or something…idk.

The SNIP software is free for small deployments. The same software rtk2go is running.

Running the Orange Pi 5 with Ubuntu 22.04 I believe.

The odd thing is it ran without issues for over a year. And just now I got another ban from rtk2go, but rtkdata.online has been fine all this time.

If you’ve got a static IP, or a dynamic IP (setup a dynamic DNS service like DuckDNS on the pi), then you can try the local caster without the VPN. If your ISP uses CGNAT then you’re kinda out of luck and TailScale is the easiest way through that.

1 Like

I upgraded the str2str binary to 34j, so we’ll see what happens. Just odd that it worked fine for an entire year.

RTKBase 2.6.0 is available

To update your base, just press the “Check update” button, and wait for a few minutes (5 to 30mn).

Ready to flash images are available for Orange Pi Zero / Zero LTS / Zero 2 / Zero 3 :
Release RTKBase-2.6.0_Armbian_24.05 · Stefal/build · GitHub

Raspberry Pi image will be available in a few days.

:warning: If you plan to use a Mosaic X5 with a Raspberry, you could have some power supply problems. I would recommend to disconnect the antenna during the first startup. It will use a little less power during the Mosaic X5 configuration.

Changelog

[2.6.0] - 2024-07-05

Added

  • Septentrio Mosaic-X5 detection and configuration
  • Reverse proxy server with Rtkbase authentication, for Mosaic-X5 web interface
  • Added description below form input. #381
  • New optional service, rtkbase_raw2nmea.service, to get date and time with a gnss receiver unknown to gpsd. (CLI only) #394

Changed

  • RTKLib upgraded to release b34j from rtklibexplorer.
  • Switch server from eventlet to gevent + Gunicorn server.

Deprecated

  • Operating systems older than Debian 11 / Ubuntu 22.04 can’t update RTKBase anymore.
  • Python release < 3.8 deprecated

Removed

  • Eventlet python module is not needed anymore.

Fixed

Security

  • Update various python modules.
3 Likes

I am running RTKBase on a RPI and having no luck pushing corrections to radio. I can get corrections via NTRIP but not radio.



These are my settings and usb to xbee adapter. Any ideas?

The Rtcm serial service slider has to be on (green). You probably know that, just wanted to get it out of the way.

Are you able to verify that the Serial output port works correctly? Maybe you can use socat to relay the port to the network and then connect with XCTU from your computer?

Yes I have had the slider turned on just didn’t in the screenshot :grinning: Thats seems like it might be the problem, that the port on the rpi isnt connected right. I had both antennas connected to XTCU and was able to send data between the two xbees but when I connect to rpi it doesn’t work. Could you explain further your thoughts of determining if it’s working?

How many clients/rovers could connect to the server/base at once? Anyone know if there is a set number?

Great work! Waiting for raspiberry 2w image to test.

Would anyone know how to share the serial connection from the base configured f9p connected to the pi feeding data to the rtkbase application while also piping the rtcm3 data from the same f9p serial connection over a socat connection? My main motivation for this is that Id like to use the application for the easy convenience of visualizing the current satellite connections and other diagnostic data while also being able to install the xbee away from the base so I can have it at a higher elevation to cover more area for corrections. My socat connection between the two pis pipes the rtcm3 data from the f9p base to another pi connected to the master xbee perfectly, but when I have this process active between the base and the master xbee radio I cannot get the rtkbase application to show any data on the status page. Anyone have any ideas on this? Thanks.

Also, does the rtcm to tcp option in the rtkbase application maintain the raw rtcm3 over tcp similar to a socat connection betweeen two computers using the raw parameter, or does extra work have to be done to convert back to raw rtcm3 after getting to its destination before sending it out through an xbee radio?