SimpleRTK2B can't achieve fix, only float

I have a working auto steer system with an AIO PCB V2.5 standard version, but instead of a SimpleRTK2B it has an Emlid Reach M+. The base is also an M+. I want to make a second PCB, this time with SimpleRTK2B, and I already have all the parts.
I switched the Reach M+ in the already working setup to the new SRTK2B to test it, and have everything setup according to the instructions on the wiki. The only difference was that in my M+ setup the Teensy .ino had its baud rate lowered to match the M+'s, I reversed that modification to the original.
For some reason it can’t achieve fix, only float. Connecting the SRTK2B directly with a USB cable and looking at the U-center program its still the same, even though it looks like it can see a lot of satellites with good signal strength. The M+ can achieve fix in the same situation.
What could be the problem? Something isn’t configured properly? Is the SRTK2B faulty?

How are you getting rtcm (correction data) to the sRTK2b? Ntrip or radio?

1 Like

I use NTRIP.

Usually float means it’s getting correction data but either your antennas view of the sats is poor or there’s some incompatibility. Turn on rxm-rtcm message on USB, then go to messages view and find the message there, see what rtcm messages it’s getting. (Hint, you can enable/disable the rxm-rtcm message with a right click on the messages view.

1 Like

Thanks! I’m going to try it tomorrow. If you think of the incompatibility of the antenna, I bought the “simpleRTK2B – Basic Starter Kit” with the SRTK2B and the antenna bundled together, so it have to be compatible.

I was able to achieve fix with the M+ (integrated in the AIO PCB + AOG), right before and after I tried with the SRTK2B which only achieved float [“Fix Mode: 3D/DGNSS/FLOAT”] (USB + U-center).
Here’s the screenshot of the messages:

If the message type in the screenshot are the rctm type then your are not sending the good ones IMO

From memory you need at least:
1005 every 10-20 sentences, base station details
1074 or 1077 for GPS constellation.

1 Like

1006 should be fine instead of 1005 but the rest are quite odd.

1 Like

The M+ used as base only have these options:

RTCM3 settings
Message type
1002 GPS L1 observations
1010 GLONASS L1 observations
1097 Galileo MSM7
1107 SBAS
1117 QZSS
1127 BeiDou MSM7
1006 ARP station coordinates

All of them are enabled, 1002 and 1006 can’t be disabled (mandatory).

Which receiver is in the M+? It seems you have a compatibility issue.

1 Like

That is an odd combination of legacy and MSM messages. This certainly does not give the full potential out of an F9P rover.

1 Like

It has u-blox NEO-M8T-0-10.

Knowing this you must update your base to a dual band reciever.

RTK is only as good as the worse receiver.
I was barely capable to achieve fix with M8Ts

Little of topic:
Even worse, according to Ardusimple, the triple band rover will have worse fix using a dual band base than a dual band rover/base combo!


With the M+ base and the M+ rover (with AIO PCB) I had fix most of the time, and auto steer also worked fine.

A dual band receiver (SRTK2B[F9P]) have to have another dual band receiver as base to be able to achieve fix?

If it’s not possible to achieve fix with this setup then my idea is to have the SRTK2B as base and the two M+-es as rovers for now and maybe updating later.