Trimble RTK + F9P issues

We did configure a Raspberry Pi3 to send message 1008, we tested using Ntrip caster, All necessary messages have been generated by Raspberry + F9P, 1005, 1008, 1077, 1087, 1097, 1127, 1230. we did not set message 4072, some guys on forums did it, is that necessary? i think not

 Here are the results

 1 - setting it as:  F9P configured as Base station, output message RTCMs  1005, 1077, 1087, 1097, 1127, 1230 > raspberry including 1008 message working just fine (we tested it on Ntripcaster all m essages ok) > Transmitter Generic radio 5w configured for Trimtalk III baud 9600 > messages sent to Generic Radio Receiver ( we tested it on computer all messages are being receiving ok) > receiver Radio connected to Trimble CFX 750 through Port A or B.  We set up the CFX 750 as RTCM Generic  and also as Trimtalk. 

             Result:  it doesn't matter if I choose  RTCM Generic  and also as Trimtalk on CFX 750 both works and I get Fix position ok.  I am getting 10 to 12 satellites + fix position, tested 8 hours straight no signal dropping. We are unsure if CFX 750 is getting glonass correction or not. Is there a way to see it on CFX 750??

             Weird results:  we took off message 1008 and big surprise. it works just fine by using Generic Radio transmitter + Receiver.  and other big surprise is:  even if I connect Ublox F9P directly to POrt A or B of CFX 750 it also works ok, we all know F9P does not generates Message 1008. Any comments?

2 -  setting it as:  F9P configured as Base station, output message RTCMs  1005, 1077, 1087, 1097, 1127, 1230 > raspberry generates and including 1008 message. All works fine (we tested on Ntripcaster and all messages showing ok) > Generic Radio transmitter 5w configured Trimtalk III link baud 9600 > messages sent to Trimble receiver radio attached to CFX 750 configured as Trimtalk 450. 

          Results: it is not getting any information from the Generic  radio. we don't know why and we can't figure out why.  We are suspecting that there may be an issue with CFX 750 configuration or  Trimble Radio receiver attached may be the problem. On the status of radio at the configuration setting it says, Radio attached ok, voltage ok all ok with the radio. any tips to give me in this case.? We have not tested it for a 372 antenna because we have no trimble radio for it, but if we attached the Harxon receiver at Port A or B it will probably work.


Try change antena name, in my case change from ublox_f9p to Trimble helped. I don’t know why it’s needed but it work.

1 Like

@kurak Which RTCM do you use ?

I have lots of them, many of them are not needed but I didn’t have time to correct it.

1004, 1005, 1006, 1007, 1008, 1012, 1019, 1020, 1033, 1042, 1045, 1046, 1077, 1087, 1097, 1127

When I was using commercial base station there were only 5 messages: 1004, 1005, 1007, 1012, 1033.
As You see, there is 5 of them which is repeat: 1004, 1005, 1007, 1012 and 1033. Probably for Trimble is needed 1008, but in commercial station there is no any 1008 message (Antena Descriptor) and it works. In next days I’m gonna try which message is necesary for Trimble and which is not. I’ll let you know about my results.


RTCM 1007 is also an antenna descriptor message. That may explain why RTCM 1008 is not needed (another antenna descriptor with a bit more information).

Always interesting to see test results on this topic.

It took a while but I have some conclusion. It work preatty well with 1004, 1005, 1007, 1012, 1033. I nad some troubles because of poor internet connection but after couple of minutes everything worked well. So, it works! Even an antena name is ublox it works correctly.

In my opinon rtcm message needs to be translated via rtklib for Trimble/TopCon etc, xbee doesn’t translate rtcm message well for Trimble and it won’t work. For good results rtklib is needed.


So you have dropped MSM messages off? I think someone here managed to run Trimble with MSM messages. Perhaps it was a later receiver model.

I’ve tried F9P with the AGCO variants of the Topcon AGI-4 with inconsistent results. AGI-4 only supports GPS and GLONASS satellite constellations and RTCM 1004 & 1012 are sufficient. Based on some previous comments here, I understand that F9P with AGI-4 had some issues with GPS satellites that do not support the modernized signal format. Do we then use less GPS satellites?

Try using a better gnss antenna. That may be the reason

Nope,after testing just in case i put MSM messages, but only 1077 and 1087 because my recievers support only GPS and GLONASS. As I said, it works without rest of messages but for me it doesn’t matter how many messages I’ll have, it have to work. I didn’t say that I use -TADJ=0.1 parametr for ublox, without it won’t work too.

For a commercial base station it uses the same numbers of satelites as for my own base. I had some issues with CMR age, but it was coused by poor internet connection with base. Using F9P with -TADJ=1 (for me 0.1) and 1004, 1005, 1007, 1012, 1033 messages work well for Trimble/AGCO-TopCon, but I added couple of more messages just to be sure.

Using better reciever will get a little bit better signal or more satelites (depends of how many channels has reciever). F9P with standatd antena do the job.


What do you mean by -TADJ=1 for me 0.1
I have an F9P trying to connect to my Trimble, using an esprtk to rtk2go

Im using rtklib for having base for Trimble/CNH/TopCon etc. In rtklib there is parametr for ublox

-TADJ=tint Adjust time tags to multiples of tint (sec)

Standard is TADJ=1, I used 0,1 for test and in my opinion work much better. After that I added couple of messages, I was writing about it befor, and it works.
So, if you wanna use rtklib you just need to add this parametr. I didn’t use esprtk, probably you need to add 1008 message in RTCM. Here you got RTCM descritpion. You can easyly add what do you need.

I’m not familiar with the issue but from this web page:

I read the RTKLIB code has been fixed already at 2017 time and the TADJ parameter should not be needed any more. I see Andreas also comments there that he has seen the issue and is happy with the fix.

Which RTKLIB version are you using or have you found a different issue that needs this TADJ parameter?

I’m running base station with str2str and rtk2go. I used version 2.4.2 b13. With TADJ parametr you may by right but in my case it wouldn’t work. Using F9P to work with Trimble it’s tricky, as I see it depends of reciever model. I’m using AG25 and it works but I didn’t try with others recievers.

In my opinion, the best way to have propery RTCM for rover is having own SNIP… I made couple of tests and it looks realy good but from the other hand it costs couple of $$.

I recently downloaded rtklib, and the latest updates I found were from dec. 2020 and the “demo5” branch.
So you mentioning 2.4.2 urged me to check if I got the wrong rtklib, and I found this comparison:

And this specially for us F9P users :slight_smile:
Updates to RTKLIB for the u-blox F9P receiver – rtklibexplorer

My bad, I was using only 2.4.2 from and I focused only on this version from 2018… However, I found something like this on raspberry and it work preatty good for me. It aslo uses str2str but it’s with GUI, so no more manually configuring. But I still believe that own SNIP is the best idea, because there posibility to easyly add/remove messages.

Discussed here too: