UDP & GPS Connection Issue

I am running Ver 5.6 and a V2 board. I’ve got all that communicating with AgIO over serial. I want to connect via UDP, but more on that later.

I have a new F9P with the XBee Bluetooth module. I cannot get it to connect to AgIO when the V@ board is connected. I have followed the instructions for Ucenter posted here: configuring the zed f9p · farmerbriantee/AgOpenGPS_Boards Wiki · GitHub. I am showing a signal in uCenter on COM4 with a Baud Rate of 460800 (as instructed in the link above). I am showing a position fix via my lat/long in uCenter, but I am not seeing any satellites in the sky. I was seeing them before I uploaded the config files as isntructed.

I am able to connect either my V2 Board or the GPS to AgIO, but not both via serial. They connect on the same port, even though the device manager shows them in different ports. When I connect via bluetooth, I am able to make a connection to the port, but I am not receviing any data from the GPS (not showing up green in AgIO).

I have tried to set up UDP, but I am not getting anywhere. I am not able to manually assign my IP address as instructed here: 05. Ethernet Setup · farmerbriantee/AgOpenGPS Wiki · GitHub or here: AgIO v5 6 Tutorial - YouTube. AgIO is calling for a 192.168.1.XXX address, but I am unable to change it to a .5 or .1. I have tried typing “24” in the subnet mask, but that doesn’t work either. So I am getting nowhere. Any ideas?

Upgrade to 5.7.2, there’s lots of improvements in networking that will help you.

When I connect via bluetooth, I am able to make a connection to the port, but I am not receviing any data from the GPS (not showing up green in AgIO).

I’m no expert and I don’t know if this is any help. I have an xbee radio on my fp9 board for corrections and needed to change baud rate to 11200 on uart2 in ucenter for communication success between the fp9 and the xbee radio. Used the ardusimple config files page for a guide Configuration Files - ArduSimple There are uart2 settings for the bluetooth xbee module there.

@Daryl Thanks for the advice. I was able to change the baud rate in uCenter to 38400 (which is the way it came originally configured) and I’m able to see the satellites in the sky again. I am still having all the rest of the troubles.

@andyinv I downloaded 5.7.2. I am playing with that version of AgIO, but not making much headway. This is what I’m looking at now.


It shows I’m connected to UDP, but I still cannot manually assign my IP address. If I leave the ethernet cable plugged in for long, I start getting this message nonstop until I unplug it.

I know this is a rookie question, but I haven’t downloaded a new version of AOGPS before. How do I get my saved information moved to the new version without having to set everything up manually?

go into the network config (green ethernet button) and screenshot it. Turn NTRIP off until you have network sorted out. You don’t need COM ports and ethernet at same time, one or the other

All tractors/fields/coverage etc will be there, some app-specific stuff (eg the last brightness you set) will need to be set again.

@andyinv I’ve had UDP and serial because of my GPS. How do I get my zedf9p to work on UDP? It takes a USB to get power and when I connect it via Bluetooth, that’s showing up as one of my COM ports.

I know Brian talked about UDP GPS in his video explaining networking, but he said his GPS was another computer.

My switch is a POE version (no router) and I have some of these: https://www.amazon.com/gp/aw/d/B087F4QCTR?psc=1&ref=ppx_pop_mob_b_asin_title, but I don’t know how to make it work because it separates power to USB and data to the RJ45 plug.

You are using a PANDA board to get the F9P over UDP, yes?

First let us assume the F9p is set to output the gps data to the bluetooth port:
I have a ublox c099 and earlier connected to AOG computer by BT.
Always at first start of AOG system, I had to shift com port speed a couple of times before GPS data were arriving. (mostly between 19200 and 57600)
Off course you need to look in Windows Device Manager which COM port the BT operate .
But apart from that I would suggest you buy a Teensy 4.1 and build a panda board, Then you can go UDP with that and UDP from PCB V2 as well, and enjoy Panda correction of roll :slight_smile:

Well the next board I build for my other tractor will definitely be the all-in-one board, but I’ve got to get this one going for now. It’s time to be spraying here and I cannot figure this out.

I think the issue may just be that my COM 4 port, just won’t connect with AgIO. It’s like there’s something already linked through that port even though there isn’t.

If I can get UDP to work for the steer board & connect the GPS via serial, I should be able to get going. But UDP isn’t working because I cannot assign my IP address. I may try this on another computer and see if I can make any headway.

I do not have a Panda board.

So when you try to connect into agio, you can have the steering module connected or the gps but not both?

That’s right. Let’s say the only thing plugged into my computer is the GPS via USB. The Device manager will show COM4 & COM8 as active. Unplug it and both COM ports go away. Plug it in again and COM 4 won’t connect to AgIO, but I connect it to COM8 and it shows up green in AgIO. Now, I plug in the V2 steer board via USB. Nothing happens in the device manager. I cannot connect it to COM4 or COM8 in AgIO. I get the same message for both ports. I disassociate COM8 from the GPS in AgIO while leaving everything plugged in, & I can associate the steer board with AgIO via COM8. So it’s either or, no matter which USB port I plug things into.

This is why I’d love to get UDP working, but the pesky IP address…

Do you have the nano ch340 driver installed?

I had a similar problem with that network setting dialog and I can’t remember how I solved the problem.
Have you tried the other settings dialog in windows?

Right click on Ethernet port in Control Panel > Network and Internet > Network Connections, select “Properties”. Then select the “Internet Protocol Version 4 (TCP/IPv4)” and click Properties bottom right.

It’s not a bad usb cable at all?

@Daryl, Your method allowed me to set the IP Address for my UDP network. Many Thanks!! Now I just have to figure out how to get these things talking. Is there something I need to do here:

GPS is connected via serial, but I need to connect steering via UDP. This is what I’m looking at now:

I need to get @PotatoFarmer to show me how to make this for my GPS, and It’ll allow me to upgrade to Teensy without scrapping this V2 board:
Developer Fun with AgOpenGPS “Ace” UDP Only. - YouTube

1 Like

There is a link to a comprehensive guide for ethernet udp/IP setup in your first post.

@andyinv asked if you had a Panda board. @Larsvest suggested you build it. This board will work along side your V2 board with an ethernet shield under the nano on the v2 board.
I built the Panda schematic on a pre - drilled board I had on hand however I would just order the PCB next time.
Board is here
AgOpenGPS_Boards/TeensyModules/Board/Panda_Board /
Firmware for teensy is here

Make sure you order a teensy 4.1 with ethernet! I used adafruit BNO085 DOF. Remove existing bno from your v2 board and put on the panda board.
Here is a link to the comprehensive teensy guide

Search the forum for “panda” and you will find answers to most questions. There is a parts list somewhere on the forum, Maybe someone can share the parts list here or put it in GitHub with Panda board?

In my opinion, Ethernet / panda board is a significant upgrade for existing boards (V2 /Kaupio V4). I used usb for a couple of years, it was a pain if connection lost briefly to the gps, had to restart agopengps. Don’t have that issue with ethernet.