UDP & GPS Connection Issue

I am beginning to understand now. I was thinking teensy/panda was a complete replacement in the new all in one board. I didn’t realize I can piggy back it on to the one I’ve got. That’s is very attractive.

I must have something wrong in my UDP setup for the steer board because I cannot get it to respond via UDP. As stated previously, it’s working with serial, just not with GPS too. See my picture in my previous post that showed the UDP subnet field blank in the middle of the screen. The bottom is showing green and connected, but I am not getting responses back from the steer board. I cannot get the subnet field to populate like in the instructions from GitHub. Any ideas?

I’m a novice myself so can only provide limited help. I would check you have the UDP ino on your V2 nano. If it is correct, sorry I can’t help.

How did he change the address for the steer box in point 15 of this tutorial? I wonder if I need to assign an address to the steer board. “Fill In” is greyed out for me. Probably because that center section is blank.

Don’t need to fill in unless you type in the box above, just change the subnet and click the blue network button on the right. Watch the video link at the top. Form about 3:30 on there is a good explanation of this.

Are you using the enc28j60 on the nano?

1 Like


Full Disclosure: I was so lost when I wanted to start this, that I had someone else build and program a board for me. I have since found more of a roadmap developing that would have helped me immensely. I just jumped into the middle of things on discourse without knowing what to do. Now I am feeling more comfortable about building my own board for my other machines.

I think the problem is that the INO on the board is for USB, and I need to load the one for UDP. The guy who built the board told me to load the INO file for UDP. I am thinking the files are here: AgOpenGPS_Boards/ArduinoModules/UDP/Autosteer_UDP_v5 at master · farmerbriantee/AgOpenGPS_Boards · GitHub. I have downloaded something from here: Software | Arduino, but I have no idea how to use it. This is what I have:

Is this what I need? Can someone direct me to a discussion, thread or tutorial about how to load INO files?

Yep it is really confusing st first. You definitely need the right ino. The following link is a pretty good guide, accept the ino files are now in the boards section on github. Match the right ino for the right version of agopengps

@CountryMile , You are looking at the correct ino. Tutorial suggests “SupportFiles.zip” and, as @elmosindustries suggested, this does not exist any longer so this is how I downloaded it.
Not sure how familiar you are with GitHub so i’ll explain in case you a novice like me, It took me a while to figure out how to download the ino from the location you have identified. What I did in the end was to go to GitHub - farmerbriantee/AgOpenGPS_Boards: Hardware PCB and firmware for AgOpenGPS Software, then download a zip of the entire folder structure (use green “Code” button!) , unzip and open the correct ino in that unzipped folder structure (from Aduino IDE as per tutorial)

1 Like

So I figured out how to open the .ino file in Arduino IDE, and I have been following the instructions in the link @elmosindustries provided. I am running into an unexpected problem with the file though. This may not be the only error I receive. I know nothing of coding. Any ideas?

I am using this file: " Autosteer_UDP_v5.ino

Did you unzip/ extract the boards folder? The ino should have extra libaries shown on the top.

Hurray!! I’ve got it connected now.

I’ve got communication with my WAS, but I’m not picking up any roll from my CMPS14. I was getting it from USB. Is there something else I need to upload for it?

I’m so grateful for your help!

Is the cmps mounted on the pcb or is it a separate module

it is on the PCB

That’s a tough one. If you press the reset button on the nano will it work?

You’re a wizard!!! That did it!

While I thought that would set me home free, I’m still having trouble connecting the GPS to AgIO. Every time I plug it into serial, it connects through COM4, and AgIO does not like COM4 as stated in my previous posts. I have restarted the computer several times and updated the driver to no avail. I’ve plugged in other devices trying to get them to take the COM4 spot so the GPS will hit a different port, but its not working.

Nor is the device working via Bluetooth. I have updated its driver and tried everything I can find on the internet to repair it, and tried different baud rates. All this while it works perfectly well in uCenter on COM4.

I’m at a loss. What do I need to get this thing on UDP?

Can I just use one of these like I’m using to connect to my laptop? Amazon.com

So you will have to modify the auto steer ino by adding a dely. Sometimes when the pcbv2 board is powered externally the nano starts up before the cmps14, and it wont show up. I’ll have a look there was a post about this. What gps boad is it? Is it the new micro board?

Mine is the RTK2B Lite board.