CanBus on '12 MF 7624 (autosteer ready)


I have followed steps 1 to 4 without encountering any issues. However, when I connected the CAN bus shield to the tractor (Massey Ferguson 7624, year 2012), the engine briefly revved up to 890 RPM and then immediately returned to idle. Unfortunately, the wheels are not turning as expected.

Additionally, error messages are being displayed on the tractor’s dashboard as soon as I plug in the CAN bus shield.

I would appreciate any guidance on what changes or adjustments I can make in this situation.

Best regards,
Jakob Hirnschall

Continuation of the discussion from CanBus for Beginners - Super Simple:

Most likely cause is the CAN high / low wires are connected backwards.

CAN High = Yellow (like the sun)
CAN low = Green (like the grass)

The other problem can be wrong CAN speed, just need to make sure your using a 16mhz CAN shield or change the code if your using 8mhz CAN shield

I have it working on a 7624. What canbus board do you use?

Im using the MCP2515 from azdelivery with an Arduino Leonardo and on the second build i used the same components buts an Arduino Nano V3.

i tried both ways

At the start of the Arduino code you will see a line with 16_mhz change it to 8_mhz

I guess that’s your problem, the CAN speed will be wrong

ill replay in 4 hours with the result :slight_smile:

I have two videos here

Video 1:
one arduino has the Valtra_Tractor_Simulator_Engage running and the other arduino has the MasseyCanDisplayAC running

Video 2:
one arduino has the ShowAllCANMessages running and the other arduino has the masseyWorkingCodeV2 running

Look at this

I cant find the x230 plug

look at the back a little bit down under.

Same happened to me. Bus speed is wrong, needs to be 250.

If you mean this line - it was on 250

I found the X230 plug. It was under the X184 plug (the round one from the previous picture where my cable was connected).

I can receive data from the tractor CAN bus with the ‘Read_All_Can_Messages.ino’ code.

However, if I flash the ‘Valtra_Tractor_Simulator_Engage.ino’ or the ‘Massey_Working_Code_V2.ino’ again, the tractor still only responds to the RPM (it increases and decreases).

The bus speed is set to 250 Kbps, and the CAN shield operates at a clock frequency of 8 MHz.

Do you have Tony’s canbus board ready to go, or an AIO with transceivers fitted? If so, I’d just go straight to them and see how you get on

I am using an Arduino Nano with an MCP2515 shield from AZDelivery.

Unfortunately, the tractor only responds to the motor rpm.

Update: I built tonys board and connected it to my f9p - works great, so does the bno085 on it - I see all values in AGO

Unfortunately I can not steer though - I have connected to the plug x230 - unfortunately unsuccessful! Then I read about the x184 and tried them. Unfortunately again unsuccessfully.
I bought a wican USB - a tool for canbus sniffing - connected that to the tractor - lo and behold, I see the can messages from the tractor in savvycan.

Small additional info: I was at my dealer and he has activated autoguide for me.

Now my question: what can I do or try?

Connect the Teensy board and open AgOpen. Make sure the tractor/arrow in bottom right corner is red and it points where the front wheels are, it should move when you manually turn the wheels.

The factory steering button must be ON.

Connect a USB to the Teensy and open the serial monitor in Arduino IDE, use the serial monitor to send the Teensy “S” then “R” then “X” I think but it will say on the screen and that will show the CAN message. Look at the 3rd data number and that must be 16 before you can steer. Try moving the steering wheel, driving forward etc and you will see this number change.

There shouldn’t be anything to “activate” from the dealer but the valve and wheel angle sensor needs to be calibrated so hopefully they did that at least.

The tractor in the bottom right corner is not turning when i turn the wheels

But i can turn the wheel now with ago
But the was says -8,4degree no matter where the wheels area