Can't get RTK Fix with NTRIP caster

I am building my first AgOpenGPS system. I have a problem with NTRIP RTK. I am using a simpleRTK2B V1 board and a free French ntrip caster ( but I can’t get it working in agopengps. This setup is working great with the Ublox U-center tool (I can get RTK fix).

The error I get in AgOpenGPS is the following :

My NTRip setup :

Does somebody have any idea of the problem ?

Thank you in advance

Can you share an image of the NTRIP settings page?

Thank you for your reply,
Here is my Ntrip setting page :

GGA interval is off increase to 5 seconds.

Désolé je viens d’essayer avec 0 cela fonctionne aussi.
Fonctionne pour moi avec vos réglages (username and password centipede)

laisse username et password vide, ça devrait fonctionner aussi

comment es tu connecté a internet?

J’ai passé le paramètre GGA à 5, sans succès. Avec ou sans username/password c’est pareil.
Pour ma connexion, j’ai testé depuis mon lien fibre en wifi et ethernet, en partage de connexion 4G depuis mon mobile, le résultat est toujours le même.
Ma machine est en windows 10.

may be a default browser problem because is not accessible from chrome but under fire-fox or edge no problem

si ublox fonctionne,

As tu bien redémarrer ta tablette?
Aurais tu empecher la premiere fois que AOG n’acede au reseau internet?
voir comme cet exemple Empêcher un logiciel d'accéder à Internet - Windows 10

Can be ideas here Error msg. - NTRIP - #12 by Ray_Jorgensen

Try disabling IPV6 on your PC (see instructions in link below). I cant remember if this was the error message I was seeing, but I found that AOG cannot ingest NTRIP over an IPV6 connection.


I opened a bug on here, but it got closed with no resolution (maybe we are supposed to raise on github instead?)

Thanks a lot for all those ideas :wink:
I tried about all : changing the default browser, restarting the PC, disabling the firewall, disabling ipv6. But still same problem.
I also re installed AgOpenGPS, tried an older version, no better results.

I have compared the network frames with WireShark between U-center and AgOpenGPS. It appears that U-center is connecting to the server and exchanging a lot of data (about 10 frames per seconds). On the other hand, AgOpenGPS is connecting well, exchange one or two frames and then nothing during 5 minutes, then connect again, a few frames exchange and nothing more…
So it is connecting well to the server but don’t seem to be able to talk to it.

One thought, is there a distance limit for the Ntrip Mount ? The one I am connecting to, is 20km far from me. Can it be a problem ?

No distance limit for the connection, accuracy decreases with distance that’s all.

Small question, when you click on “confirm IP” the IP address below remains the same ?(

yes for centipede

Yes, always the same IP.

Well, I remplaced the centipede caster by rtk2go, with the same mount, and it is now working like a charm :grinning:.
Very stange problem, but it is working now, so I can go further in the project.
Thanks to all for your help.

Looks like some other people had the same problem with no real solution other than changing the server : Ntrip Client for AGOpenGPS | Page 8 | The Combine Forum

I also had a connection problem this morning after restarting my computer. I found that by clicking on confirm IP in NTRIP configuration the IP address was transformed into fe80 :: 250: 56ff: fea4: 8801% 3 .
The problem disappears when I open the page in chrome.
It’s strange but if it can be useful to others …