Dual GPS PCB v1.3

The last version can be found here

The w5500 ethernet connection is working with the code of Matthias (mtz).
It is stackable with the v4 board of Kaupoi.

Hello everyone,

I designed a PCB for the dual GPS Setup of Matthias.
I have a prior version on my desk working. For the actual version I only changed the TX/RX pins so it is compatible to the basis code of Matthias. Also made the holes bigger to fit M4 screws. The PCB fits in the following housing: RND 455-00460. Its quite big, but you never know :wink:

With 14 V the current regulator is not getting warm. It should work up to 37 V, but I haven’t tested it.
The Reverse Protection is working. If it’s reversed a red LED is on.

The Connection for RTCM is connected between both boards. Normaly only one direction is necessary.

The USR-TCP is not tested yet. The idea is to use Matthias code in USB mode and grab the data to send out over LAN. So just an untested Option.
Edit: I tested it, and it seems to work. So an easy solution to get the ESP32 over LAN.

The WiFi LED is on Pin 13. There are two other unused LEDs on 5 and 21.

You can get all the SMD parts assembled from www.jlcpcb.com. You only need to solder the female header and plug in the Node MCU (https://amzn.to/2zDVYt5) and the two Ardusimple boards.
5 pieces cost 64€ including shipment to Germany. 10 PCBs cost 80,40 €. It took two weeks from uploading the data to have it in my hands.

Since its not possible to upload *.zip just delete the *.txt extension.

AgOpenGPS Dual GPS v1.2.zip.txt (238,9 KB)


Feel free to comment or edit.


I’m new to using the NodeMCU and I’m having some trouble compiling the code in the Arduino IDE. I have been trying to google solutions but appear to be stuck.

I’ve installed the ESP8266 Arduino core per these instructions: Installing — ESP8266 Arduino Core 2.7.1 documentation

I’ve also installed the ESP32 Arduino core per these instructions: https://github.com/espressif/arduino-esp32/blob/master/docs/arduino-ide/boards_manager.md

I’m still getting all kinds of compile errors in the Arduino IDE for AsyncUDP.h, freeRTOS, etc.

Do I have to manually move these libraries into my /libraries folder or have I missed installing something? Any help would be greatly appreciated!


1 Like

Have you unpacked all the files? In the Arduino IDE, do you have more then one tab?

I had a related problem with the autosteerPCBv2.ino, I got a lot of faults when I used the ino directly from the unpacked support folder (downloaded from github) But when the whole library was copied to a new location on computer and opened ino from there, then compiling went fine. I seems that the .inos in the support folder is write protected!


Do you have the reference for the SMA connectors and short cable for passing through the box ?
I am interested in.



It is just any sma pigtail. Search Amazon or eBay. For example:

Double trouble

Hi Benjamin, we had a short conversation about dualgps on telegram in march or april. Sadly i lost your contact and our chat with my new phone and i dont know which benjamin on telegram group is you. Ive seen that you are from Wegberg and you are using sapos NRW. Im from Korschenbroich. Are you still using dualgps with sapos and its working? maybe you already read about my dualgps problems on telegram. My dualgps worked great for 2 month, but since the sapos error 2 weeks ago, it doesnt work anymore. Are you having the same problems?

Greetings Andy

Hello! Does anyone else use this board? Does it work stably?

Can you give more infor about Ethernet connection ? What usb-LAN board do you use? How does it work with AOG - via UDP or via another LAN-usb converter?

A guy uses it and we found out, that RX and TX lines are not x from F9P to ESP32. Doesn’t realy matter, but the GPIO config for this board and my software is:
setup zone in ESP code or Webinterface:
RX1 16
TX1 27
RX2 17
TX2 25

1 Like

Matthias, may be you know, how did he configur the USR-TCP converter? Should I add some code to ESP32 to make UDP working properly with this converter?
is it possible to use ESPDUINO and utilize RX0 TX0 output on it?

Sorry I don’t have the hardware, so I don’t know

I would love love love to be able to use my dual antenna with ethernet instead of wifi or usb! :wink: :slight_smile:

I tried to handshake esp32 and enc28j60 - cant figure out how to connect properly the hardware interface. ENC28 starts to heat after few minutes.
I connected
VCC -Vin(5v)
Tries to use this lib GitHub - UIPEthernet/UIPEthernet: UIPEthernet library for Arduino IDE,Eclipse with arduino plugin and MBED/SMeshStudio (AVR,STM32F,ESP8266,Intel ARC32, Nordic nRF51, Teensy boards,Realtek Ameba(RTL8195A,RTL8710)), ENC28j60 network chip. Compatible with Wiznet W5100 Ethernet library API..
Still unfortunate ((
May be someone can suggest the right way for hardware connection.

Sorry, i haven’t been here for a long time.

You do not need to add code to the ESP. As far as I remember you just need to sent the data out to USB.

Matthias, I’m wanting to try this board, with some changes. Want to move the mounting holes a little to stack Kaupoi v4 board above it. Can you confirm whether or not it will work with your code ? I would want to correct the rx and tx to match, but otherwise nothing else

I cant figure out how to get this into jlcpcb. What do you mean by deleting the .txt extension

and what is the size of the board jlcpcb wants a size

After you download it, go into your downloads and right click on it, click properties, then at the bottom of the box click unlock. Now right click on it again, and choose rename. Take .txt off the end. Now you can extract it.
Jlc will want the gerber.zip in that folder so in jlc choose upload Gerber, then go select it from your folder