GPS Setup

Thanks all for the discussion.

I have the autosteer PCB functioning and am working with the GPS.

I have a U-blox F9P connected via USB to my PC. AOG says my GPS port is connected. I have my Baud rate set at 38400. The NEMA string says “Initial Setting”. Data Source is Fix From GGA (NMEA Hz is set at 2). Do I have to set up the receiver in another program. The receiver worked with AOG version 3. Any guidance would be helpful.

You need to set up the F9p in u-center. There should be a Config file here: Ublox F9P - Config for rover
Remember to save the Config after uploading.

Thank you for the response.

I can upload the Firmware file. However when I try to transfer the Config file to GNSS I get an error message that “there were errors or conflicts”. Is this normal?
Screen Shot

20201002_210627 This is the Ublox I am using.

I also do not get any indication that the firmware update ran when I hit go. I have learned that when the firmware is successfully updated it should run messages in the command line and end with “Success”.

I think you should use a baudrate of 115000 or 250000 for firmware update.
Edit: 230000

for the update it is necessary to connect by the usb socket on the antenna side,
i also had this problem and solved this way

You’re in the firmware upload, that’s not where you’re uploading Config files. There’s a difference between firmware and Config files. I’m not with my pc now but l’m sure you can find information here on the forum, for instance in this thread

Make sure you use the corresponding Config file for the right firmware, now the newest firmware is 1.13.

1 Like

From looking at you picture it looks like you have your usb cable plugged into the wrong side of the ardusimple board for programing

I am back at this project. Thanks for the tip for attaching to the GPS port.

I now have the receiver connected to ucenter and it is reading my location. However, I still cannot get the firmware update to load. I have been searching on the internet and others are having firmware issues as well. Can someone check my screenshot and give me some idea what might be my problem. See screenshot.


Below is a screenshot of the firmware version in use.Capture1

It seem that you are trying to upload frimware 1.12 to an already 1.12 f9p and at a baudrate of 921 600.

Be sure the file to upload is 1.13 and set the baudrate to 230 000.

I was able to upload the new firmware version 1.13 and now have the following message when I upload the config file from MortonP. Capture3

Is there another config file to use for firmware version 1.13?

That worked. Not sure why but I will go with it.

Thanks again.

Question: Now that I installed the firmware update and the config files agopengps says “lost RTK” .

I am not running an RTK base station. The receiver worked fine before I updated the firmware to 1.13 and the config file. Did I do something wrong?

I am just looking to simple autosteer at this point to learn how it works.

There is an alarm you can set on of off for RTK. Set off if you don’t use it.
In data sources

Thanks for your help. I am anxious to install this on my tractor now that I know my table model works.

the f9p is a rtk receiver. so you should setup a base station or get a rtcm correction elsewhere.

autosteer without rtk do not realy works very good.

if you like to test really without rtk you might turn on sbas in receiver config for more accuracy.

The F9p works well without rtk, I did this autumn seeding in “single” mode.
But Aortner is also correct, because when you come back to the field an hour later, the A B line has moved some centimeters to the side, so you have to center the line again.
U-turn also works well.
But my winter project is to set up a base.

1 Like