Steer motor pulsing/running on off

I have finally got the auto steering all plumbed up to tractor and have tried using a smaller motor than I would like as can’t get hold of a phidgets motor for now. It has around 2kg of force and 600rpm and although it will steer the tractor it only runs in pulses(on for 2 secs then off for a sec then on for 2 sort of thing) am I rite in saying the motor torque will be too low although it seems to turn the steering no problem?also the gps signal can randomly jump off track momentarily then come back stable again!could this be connected?thanks

It looks like a powering issue. Can you tell us how you power all the stuff?

What gps rate are you using? Hz? Are they set the same in aog and f9p?

It’s a pcb v2 board,cytron motor driver converted to 24v. Powered 12v from tractor to relay on board. The final installation will use a hydraulic valve but would like to find this fault first. When the steering is activated the dir indicator light on the cytron will flash for around 2 secs as the motor is moving rather than a constant movement until it reaches the ab line. So the wheels start stop bassicly until reaching the centre,but the motor does speed up and slow down not just on and off completely

Yes I think the hz are the same 10 but will check that

I’m no expert by any means, but have you tried increasing the gain in the autosteer settings?

If you manage to find a solution. Can you please share.
I think i am having the same problem. Motor pulses for tiny moments.
What i found is when i run it in simulation mode the motor runs perfectly.

So i wonderd if there was tp much current to handle for my laptop. But i can run te motor in agopengps prefectly while at the same time running the gps in u-center (with rtk fix)

1 Like

Yes I have tried changing various settings on the drive controller which have the rite effect that you would expect but still always has the pulse type movement on the motor regardless of gain etc

I forgot to mention it doesn’t seem to be load related now I have tried the motor not touching the steering wheel it is still the same

my problem was solved with these files. Ublox F9P - Config for rover

did you try running the motor in simulation mode ?

In sim mode it acts just the same so would seem not to do with gps signal. Also noticed a light on the arduino flats at same time as motor pulses so seems to be a prob with the signals from arduino

I had a similar problem and the reason was a faulty arduino nano. The processor was getting hot. I replaced it for a new one and the problem disappeared.

I think I will try replacing the nano first as this seems to be where the problem is,after that I’m not sure what else it could be

Please share your outcome if it works…

  • right setting in F9P?
  • bad Nano chip?

I am just waiting on delivery of a new genuine nano to try that :+1:

So I have replaced with a genuine nano and no change,but have found it’s a prob with the usb connection. If I remove the gps usb from the hub the steering is smooth. So could there be a prob with usb hub?or can I not use 2 usb cables through a hub into the 1 on the tablet?

seems weird,
You can always test this by using a computer with enough usb ports. Or trying other usb inputs on the hub.
Can you please tell us what hz it says you’r gps is running in the application?

Open agopengps → connect you’r gps → at the top left/middle there are white letters saying numbers.

Also limit gps msgs to gga & vtg

An F9P will go get crazy if it’s need to send to much data at an high refresh rate (8hz or higher). So be sure you have the right config file loaded to the F9P. Can be found here on the forum.

Thanks for the help everyone I think that’s it sorted,rate was too high causing everything to go crazy (gps and steering) seems nice and smooth now motor working well :+1: