Teensy disconnecting?

Is it normal for the teensy to continually connect and disconect from the computer after uploading the ino. Files. Because of this issue i cant get the teensy to put anything out on the serial monitor. Just wondering, using the newest files from brians folders. Thanks

Everything works fine for me if I use the teensyloader with the hex files, but I had the same issue when using Arduino IDE. I haven’t figured it out yet, but my next step is going to be trying an older version. @Pat suggested there is possibly a bug in the latest INO.

Same here
The ino files seems to work for some people?
but I confirm they didn’t worked for me with Arduino ide 2.x and 1.8.x, lost several hours reinstalling ide ti try to solve this, very frustrating :face_with_symbols_over_mouth:

Same here. I spent the whole afternoon reinstalling Arduino IDE, and tried it on a different computer as well. Both computers I used, are Microsoft Surface pros. I don’t imagine there’s any chance that has something to do with it?

Did you follow the wiki suggestions. Using 1.8.x together with teensyduino 1.57

1 Like

Hi i had this issue this is how i got around it
Code wasn’t up loading correctly.
Teensy 4.1 not recognised.

Reset teensy.
Memory Wipe & LED Blink RestoreTeensy 4.1 will fully erase its non-volatile memory and return the flash memory to a simple LED blink program if the program button is held between 13 to 17 seconds. The red LED flashes briefly at the beginning of this time window. During flash erase, the red LED is on bright. When completed, Teensy 4.1 will automatically reboot and run the LED blink program, causing the orange LED to blink slowly.

Push the in reboot button under operations heading in Teensyduino program

(Teensy is hex.file until coded for usb)

Then i Copied simple flash code to teensy (to code usb and check to see if it worked)

Check serial Monitor in Arduino IDE for blink code

Sign up and Download github desktop version for files
As directly downloading didn’t work from github didn’t work code was corrupted

Compile agopengps files to teensy

Try uninstalling teensyduino and make sure to install the 1.5.7 version.

I had this issue, turns out there’s 2 lines which need deleting in zADS1115.cpp
Delete or comment out those wire.end and wire.begin lines at the top.
These lines get called before void setup which causes the teensy to continually hang and reboot

ADS1115_lite::ADS1115_lite(uint8_t i2cAddress) {
	_i2cAddress = i2cAddress;
	_gain = ADS1115_REG_CONFIG_PGA_2_048V; /* +/- 6.144V range (limited to VDD +0.3V max!) */
	_mux = ADS1115_REG_CONFIG_MUX_DIFF_0_1; /* to default */
	_rate = ADS1115_REG_CONFIG_DR_128SPS; /* to default */
1 Like

No bug in the INO from what I can see. With 1.57 of Teensyduino and IDE 1.8.19, the .hex I produce is binary identical to the one on the boards repo. And it uploads fine for me.

Looking more like a Teensyduino 1.58 issue at this time.

That doesn’t bother my IDE 1.8.13 with Teensyduino 1.5.7. I can compile and upload that code all day long.


I never loaded this blink but i just found it now

I use Arduino IDE 2.0 had quite a few problems with it on my desktop PC, but works faultlessly on my Panasonic Toughpads.

Did have one Teensy lockup last week when flashed with desktop PC, redid on tablet and worked perfectly.

But which teensyduino 1.57 or 1.58
Or were the pc upgraded or downgraded from 1.57 to/from 1.58

I don’t think you need to install teensyduino with IDE 2.0 Teensy support is integrated.


1 Like

Okay I see
You just have to install some other extra files to be able to use 2.0 with teensy

I successfully loaded the latest INO several times last night. It appears (so far anyway) that teensyduino 1.57 has fixed the issue for me.