All in One PCB

I assume it is a parts shortage at JLC? Have you ordered the boards already? There are alternate parts available right now at LCSC

2SC2884 Jiangsu Changjing Electronics Technology Co., Ltd. | C24205 - LCSC Electronics

Also Chinese National day holiday is coming up. Many Chinese companies are closing in some fashion. Jlcpcb is shutting down Sep 29 and will restart Oct 4.

I uploaded 1.32 SingleAntennaRover to f9p… I had some other configuration on it I found around here on forum… bit it doesn’t work with latest teensy code my guess…

Hello, I’ve find this drawing on previous messages but some dimensions are missing. Can someone give me them ? It’s for making the face plate for hammond box with v4.1 micro
Original drawing was from vili

I think you’re after this:

G’day guys
putting together my second board of the original v2.4 AIO board and am confused about what i did to get 24v into the first board. On my first board I’ve cut pins 3+7 and wired them to the 24v in screw terminals, which means I dont have 5V Low and Lock? Thought i needed 5V Low… The ampseal is already soldered in but could I just supply 24v to Canbus pins (16+17) and jump that to the 24V in? Or will it blow something that’s used outside of canbus? (using phidgets).

Is it possible to get EasyEDA files for the V4.1 micro board?

I didn’t find it on Github
here is a post from v4 AIO tread with the file

I made an order from JLCPCB. I left all the settings as specified, just uploaded the files and always pressed OK. This is now the confirm parts placement. I’m a bit confused about the original parts placement (picture on the right), which is completely out of place.

This is the JLCPCB corrected version. Do the red dots have to be pushed onto the white ones (e.g. yellow marking)? Sorry, but I have no idea about that.

What do the red dots mean?

Your circled red dots denotes pin 1 on those parts, and the white dot on the pcb is also for pin 1 so they look correct. The misalignment of all the parts is common and it’s obvious where they should be so they make the correction.

1 Like

Hi, I’m assembling V2.4 STD board now. Teensy is flashed with all-in-one v2.x software. 12V solder joint for Cytron is done. Cytron green led is on but 3rd led on PCB for steer is off. AgIO doesn’t see steer too. I have checked PCB connections from teensy to MD13S. It looks fine. Any ideas?

How are you powering it? Try power via the ampseal

Next to the ADS1115 there’s a header I’d start my investigation there.

I’d check if I can measure the right voltage (5V) there:

Also ADS1115 is connected via I2C and requires a 3.3v to 5V level shifter (circled at the bottom)
There’s an SMD and a THT option as well. Please check if you have those (it’s under your cytron)

Thanks for answer. In header next to ADS1115 there is 5V. I have both smd shifters under cytron.

Do you have a wheel angle sensor connected?

No, I don’t have WAS connected but I can see some photos without WAS and led is red there. As an example:

Yes all three leds should like up, have you tried wiggling/moving the led that isnt working?

I’ve had several not lit up, but slightly moving the Led has bought it to life.

Don’t forget the jumpers to select the Cytron output, but this doesnt stop the Led lighting up.

I have tried to light up the led with external power supply and it lights up. Suddenly it has started to work. It lights up first now when power whole PCB. You were right. It looks like current from power supply has welded something.
But AgIO still doesn’t see the Steer. GPS and IMU are active.
I don’t have WAS. Is it needed for AgIO to see the Steer?

Have you changed the ip address on your tablet to match?

And turned UDP on AgIO?