Software Problems

Hello all, recently I put together my own AGOPENGPS setup, using the schematic on the main page seen here: image everything thing was working on version 3.0.7 with the PCBv2, but the switch wouldn’t work so i couldn’t activate the Motor for wheel correction, I’ve tried to change the pins and relays to the correct ones that match the schematic, any help is greatly appreciated thank you!

Welcome to the forum :slight_smile:
First Did you drive faster than 1 km/h otherwise you can´t turn on autosteer. (Except from when in DRIVE in the autosteer setup)

Do you have a PCBv2? and just want to check why it doesn´t work with this schematic?

The Schematic you found is some years old.

Have you seen the new Support folder on the github? find it in top of this thread: Release v4.3.10 - Finally!

Without PCB you could figure out the new pin numbers used with program v4.3.10 by looking in AutosteerSchematic.pdf
BUT in v4.3.10 you also need a ADS1115 to connect WAS to I2C as the A0 no longer work.
For testing in SIM you can leave out a WAS.

Check the setup videos from Brian by clicking the youtube button at top of the forum screen.

we don’t actually have PCB V2, that code worked fine for steering angle sensor but not the motor or switch, so v4.3.10 doesn’t work as its just plugged straight in without ADS1115, the only code that is semi working is one called: Autosteer_switch, which is working on V4, motor is spinning when i click drive and switch is showing up, but the steering input i receive is in the tenths not thousands ( E.G should be : -1xxx, not -1x ), is there some way i can modify / fix this code so it is recognized properly and AGOPENGPS can receive input? sorry kind of new to C#, and trying to learn it along the way. Also i can post a picture of the way we set it up in the morning, ( Currently 11pm In Australia right now )

Program 3.xx can work with Autosteer_switch.ino
Program 4.3.10 work with Autosteer_USB_4.3.10.ino
I strongly suggest you to move to 4.3.10 and get a ADS1115
Using 4.3.10 settings of Nano is done from AOG itself.

If you stay on 3.xx you don´t have to change things in Program in c#.
What you want to change — if you want to change pin numbers of Nano, is in the xxxxx.ino using the program Arduino ino.

The pin numbers in the schematic are old, read the correct numbers in the Autosteer_switch.ino you use, just after setup ZONE, looks like what you see below! (there were a change in pin numbers 2 years ago when PCBv2 came out)
BUT YOUR PICTURE ABOVE fits this pinout from the autosteer_switch I found (Pin 6 is the other PWM when using IBT_2)
Did you set that you use IBT_2 in settings part of Autosteer_ino? The first setting must be 2 !
AND did you click Auto/manual, in AOG (3.xx) Vehicle settings/Guidance, so it says Auto and get green?

#define STEERSW_PIN 3 //PD3
#define WORKSW_PIN 4 //PD4
#define PWM_PIN 5 //PD5
#define DIR_PIN 6 //PD6
#define LED_PIN 7 //PD7 Autosteer LED
#define W_A_S A0 //PC0 Wheel Angle Sensor
#define Dogs2_Roll A1 //PC1 EADOGS2 Inclinometer

1 Like

ive set all that up, but it says Oops NC on some versions of 3.0, only v4 is working, also on v4 its only showing single numbers input back from the wheel angle sensor so its not getting any input back from it, is it possible to fix the single numbers or?

Oops NC is only a matter of com ports (for the Nano) in windows.
Until around 4.1 the autosteer_switch should work.
4.3.10 demand its own ino and also the Ads1115.
It is OK to connect to AOG even without a WAS or Ads1115, just the steering numbers don’t move.
Watch videos, some shows which numbers are what.
Also you might experience that AOG freeze, if you connect wrong com to gps receiver port. Find solutions about freezing elsewhere in the forum.
Remember to disconnect /shut down arduino program, before trying to connect to AOG.

If that’s the case then why isn’t it picking up the wheel sensors input in AOG? It’s only showing single numbers with Autosteer_switch and AOG can’t recognise it

To understand you I need a picture telling where you see the problems

Ill send a photo of the things I’m talking about and our setup, currently at school now, also if I wanted to integrate the PCB is it gonna make a big difference or?

I started 2018 same way as you, uncertain it could ever work.
Today AOG 4.3.10 and PCB, certainly work well, and a lot easier for us to help because many connection faults are eliminated. There is a lot of how to on the forum, just use the magnifying glass at the top. You might find this :slight_smile: PCB (V2) Assembly Video first post in the thread.
At the end of the video it’s showing how to set up system in AOG v3.xx
Remember not to buy the mma, as the bno085 or cmps 14 mentioned elsewhere, have replaced it.
Again watch videos and use program in Sim to learn.

so i should buy the bno085 PCB? would that work fine if i follow the youtube tutorials listed, also where did you buy your PCB from?

Search is your friend. Getting started category is good too Documentation of my way to autosteer
You might also like this one : New Schematic for Non-PCB users
Note: Autosteer work ok without any of the components that add roll or /and heading, first setup of steering-settings could even be easier without them.

Ill setup with that schematic that you listed and ill update how it goes, thanks for sending that though, very much appreciated

did the new Schematic and everything is working fine on our version, wasn’t working on etc…, more than likely because we do not have a ADS module, only issue I’m getting now is when I turn left and it recieves negative input from the wheel angle sensor the motor stops spinning, perhaps a issue with the wheel position zero and gain in AGOPENGPS?, but everything else is working :slight_smile:

Do you mean AOG version 4.4.xx?

Last working in real life is AOG version 4.3.10
The coming v4.4 or what it might be named, is still for test only (mainly in SIM I think)

v4.4 is for test, and he needs a new .ino., people are working on it :wink:

Use last release 4.3.10

no i meant that the versions V4- 4.3.1 wasn’t picking up steering angle sensor but everything else was working, because we don’t have a ADS module it would do that? but all the Version 3 builds work, just got to fix a issue where the motor doesn’t spin when the wheel turns left and the input becomes negative

You need ADS

If you mean don’t spin in ver 3, when it has to turn left, could be because you chose cytron in setup, instead of ibt_2

I’ve chosen IBT2 driver in the setup for that versions code, but only spins one way, also it’s going way past the readable limit (-100) showing up in the steer section under auto steer, but if i move it a litte, like ( -6 ) itll move that way, perhaps ive messed up something with wheel zero point or?